Robert Alan Shannon's Discussions (164)

Discussions Replied To (162) Replies Latest Activity

"I , too , was on a first date , drove to the wildlife refuge and parked for a while.…"

Robert Alan Shannon replied Jul 11 to Completely Dead

6 Jul 11
Reply by Robert Alan Shannon

" I can't recall finding any  grease pencil markings  under the hood or anywhere else…"

Robert Alan Shannon replied May 15 to Crayon markings and markings in hoses

6 May 15
Reply by William R Conte

"Karl , I believe it attaches with a ring type crimp fitting  under the bolt head  at…"

Robert Alan Shannon replied Apr 13 to Ground Question

13 Apr 15
Reply by Tony and Ginny 429

"Russ ,you are right on; I ordered an O2 sensor for the wife's car on Feb 2nd from Ch…"

Robert Alan Shannon replied Mar 9 to passenger side lower door moulding

3 Mar 10
Reply by Joseph Pagliuca

"Thanks again, Jason. A very valid point indeed !  Yeah, I'll just wear a filter mask…"

Robert Alan Shannon replied Feb 19 to Headliner insulation

4 Feb 19
Reply by Robert Alan Shannon

" Thanks Jason,   yes , I want to just get rid of the headliner and  padding , it's …"

Robert Alan Shannon replied Feb 19 to Headliner insulation

4 Feb 19
Reply by Robert Alan Shannon

" Hello Scott in Cleveland , Ohio!  I was born there , I'm a '59 model myself. Haven'…"

Robert Alan Shannon replied Feb 15 to Motor yaw control arm service

53 Feb 17
Reply by Tony and Ginny 429

"Thanks Ben, I guess its kinda of an optical illusion  the way that chain looks to me…"

Robert Alan Shannon replied Jan 30 to New timing chain and gears...how much slack?

11 Jan 31
Reply by Anders

"  Doesn't look right to me ; why is the chain not sitting down all the way  across t…"

Robert Alan Shannon replied Jan 29 to New timing chain and gears...how much slack?

11 Jan 31
Reply by Anders

"Dagnammit, I forgot about the different crankshafts  used in 64. Seems like I always…"

Robert Alan Shannon replied Dec 27, 2019 to Help decoding engine block

6 Dec 28, 2019
Reply by Jason Edge

RSS

Photos

  • Add Photos
  • View All

Forum

Bendix Power Brake Unit Power Section

Started by Mathis Richter in 1963/64 Cadillac Specific Discussion. Last reply by Chris Codd yesterday. 7 Replies

Hi,I have a huge problem my POWER SECTION of the ``Master-VAC Power Brake unit 9´´Diameter ´´ from Bendix is Broken and I can't open it to replace al the rubber parts did some of you have auch Power…Continue

Third brake light -help please.

Started by paul k in 1963/64 Cadillac Specific Discussion. Last reply by Jason Edge yesterday. 8 Replies

Did anybody from the club install third brake light in the rear window in his Cadillac? I have problem to figure out how to do it. Can I just run wire from break pedal switch and second wire connect…Continue

Extra speakers in the cadillac.

Started by paul k in 1963/64 Cadillac Specific Discussion yesterday. 0 Replies

Ok, I have another question. Since I will run wire for a brake light I might run speakers wires.I would like to install 2 extra speakers or maybe 4. What is best option. I do have 2 speakers already-…Continue

429 and 400 trans. for sale

Started by Mark C Bills in For Sale. Last reply by Tony and Ginny 429 on Monday. 6 Replies

I have an excellent running 429 with 400 trans.recently removed from my 64. It has electronic ignition, new water pump,new fan and clutch(not pictured),new fuel pump,Holley 650 vac. sec. carb. with…Continue

Blog Posts

1964 Cadillac Fleetwood sixty special / transmission dipstick needed

Posted by Pablo on September 20, 2020 at 9:57pm 1 Comment

How are you doing folks, I’m looking for a transmission dipstick, any info I will appreciated, thank you very much

1963 Cadillac hood driver side hinge

Posted by Steven on September 16, 2020 at 9:23am 1 Comment

Hello,

 Does anyone know were I can buy a 1963 Cadillac hood driver side hinge or is there any other hinge that would fit? 

Thanks

Steven

Bad Guage?

Posted by Karl Schwarz on August 26, 2020 at 3:08pm 6 Comments

So I am troubleshooting my fuel gauge issue. I bought a new sender and tested it. It  it goes from 1-ohm (empty) to 35-ohm (full). When I test it (outside the tank), when the float is in the up (full) position it only moves the gauge to about 1/2 full. When at the bottom (empty) position the gauge shows empty. This is the same issue I have when I fill and then use the gas in the tank - the gauge never reads ore than half full. Based on what I've read on this thread it would seem like the…

Continue

Website

Posted by Fritz Seitz on August 11, 2020 at 2:35am 0 Comments

I have been working on a website-----www.fritzsautorepair.com-----

Does anyone have suggestions?

Videos

  • Add Videos
  • View All

© 2020   Created by Jason Edge.   Powered by

Badges  |  Report an Issue  |  Terms of Service