I bought this beauty a year ago and at that time the AC system was flat.  I replaced a line that had a huge hole in it, pulled a vacuum, charged it with R12 and it started making cold air !!!! Oh happy days !!!

AC runs great until I take the transmission out of Park (and put it into Drive or Reverse).  At that point it just fan shuts down.  If I put it back in Park the fan starts blowing cold air again. 

What the heck ?   My only thought is that it might have something to do with the neutral safety switch (it hisses when I put car in Drive). 

Any suggestions ??

Views: 195

Attachments:

Reply to This

Replies to This Discussion

My above post should read -
I do second Kurt's suggestion

Sorry Kurt !

Enjoy

No problem Tony. I've been called much worse : )

Hi Guys,

Thanks for all your suggestions.  I have been troubleshooting the AC pneumatic system and all things point to the "rotary valve" on the passenger side interior.  I bought the $20 manual and it gives direction on how to recondition the rotary valve.  It doesn't sound too difficult.  Has anyone done this before and do you have any advice ?

Robert

I did disassemble my rotory valve on the servo behind the glove box but it was some time ago
I just put it back together the way it came apart with no issue as i recall
The rotory valve on the back of the confort control controls was a bit more difficult to work with but do not recall the details

The point i want to make is i did find debri in that rotory valve and the rotory valve behind the confort control controls so cleaning the valves was rewarding and a good idea to have the AC work correctly

Do what you must to be sure all your hoses are holding a vacuum ( no air leak )
Plug what you must to have the system hold as much of a vacuum as you can and then you can get back to resloving the leaking hose or leaking vacuum valve for example
You will be establishing the parts of the CC that you will need to be replacing in the future at this same time

Enjoy

Thanks .  Just got done refinishing the valve.  No big deal.  Not very intimidating (once you've done it).  Thank for the advice.

RSS

Photos

  • Add Photos
  • View All

Forum

fuel pump

Started by Kim K Kaiser in 1963/64 Cadillac Specific Discussion. Last reply by Anders 1 hour ago. 4 Replies

I am gathering up some stuff to put away for the potential trip home in oct/nov from MT to MS in the 63 cdv.i thought a fuel pump may be a good piece to have nearby,  Are the newer ones like you can…Continue

off the wall question

Started by James Fejerang in 1963/64 Cadillac Specific Discussion 1 hour ago. 0 Replies

 Could anyone please tell me why on some models of the 64 devilles, the Bezel, Turn signal (LH upper) is clear and the other one RH Bezel is chrome.  Sorry if this is a stupid question, but i have…Continue

rear seat speaker grill

Started by Kenneth R Hudgins in 1963/64 Cadillac Specific Discussion 10 hours ago. 0 Replies

Looking for a rear seat speaker grill for my 63 EldoradoContinue

Classic Cadillac Parts For Sale - Misc Items

Started by Jason Edge in For Sale. Last reply by Jason Edge yesterday. 159 Replies

I have posted a few Misc items over on my Classic Cadillac Parts Facebook page at…Continue

Tags: classic cadillac parts, classiccadillacparts

Blog Posts

Starter Solenoid replacement-how difficult? Where to buy?

Posted by Norman Silverman on August 20, 2019 at 8:24pm 8 Comments

Hello All.

I believe the starter solenoid has gone bad in my 64 DeVille. When I turn the key, often all I get is a click, then if I try a few times again the starter turns perfectly. All battery cables are on tight and the battery is good. So, I believe this problem is the solenoid. Where do I buy the right solenoid and is it necessary to remove the starter in order to swap it out? …

Continue

Frame Markings

Posted by Gene McIlroy on August 12, 2019 at 6:26pm 1 Comment

Just got my frame back from powder coating so thought I would post photos of the front and rear frame markings.…

Continue

Lining up the drive shaft

Posted by Dominic Salemi on August 12, 2019 at 5:47pm 2 Comments

Can anyone shed some light on how to position the complete drive shaft in the correct position? I want to make sure my drive shaft is installed properly.

Thanks

Dominic

Upper A Arm Rubber Bumpers

Posted by Gene McIlroy on August 12, 2019 at 1:30pm 3 Comments

I have found a very good replacement part for the Upper A Arm Bumpers.  The top part is identical to the originals the bottom can be used as is or after a few minutes with a belt sander can be ground to the V shape as the originals were.  The replacement bumpers are for a 2001 to 2005 S10 Sanoma or Blazer.  Part number is on the box in the photos.  First photo is the box next to the box is the S10 part and an original.  Next photo shows my sanded down part next to an original.…

Continue

Videos

  • Add Videos
  • View All

© 2019   Created by Jason Edge.   Powered by

Badges  |  Report an Issue  |  Terms of Service