I bought this beauty a year ago and at that time the AC system was flat.  I replaced a line that had a huge hole in it, pulled a vacuum, charged it with R12 and it started making cold air !!!! Oh happy days !!!

AC runs great until I take the transmission out of Park (and put it into Drive or Reverse).  At that point it just fan shuts down.  If I put it back in Park the fan starts blowing cold air again. 

What the heck ?   My only thought is that it might have something to do with the neutral safety switch (it hisses when I put car in Drive). 

Any suggestions ??

Views: 208

Attachments:

Reply to This

Replies to This Discussion

My above post should read -
I do second Kurt's suggestion

Sorry Kurt !

Enjoy

No problem Tony. I've been called much worse : )

Hi Guys,

Thanks for all your suggestions.  I have been troubleshooting the AC pneumatic system and all things point to the "rotary valve" on the passenger side interior.  I bought the $20 manual and it gives direction on how to recondition the rotary valve.  It doesn't sound too difficult.  Has anyone done this before and do you have any advice ?

Robert

I did disassemble my rotory valve on the servo behind the glove box but it was some time ago
I just put it back together the way it came apart with no issue as i recall
The rotory valve on the back of the confort control controls was a bit more difficult to work with but do not recall the details

The point i want to make is i did find debri in that rotory valve and the rotory valve behind the confort control controls so cleaning the valves was rewarding and a good idea to have the AC work correctly

Do what you must to be sure all your hoses are holding a vacuum ( no air leak )
Plug what you must to have the system hold as much of a vacuum as you can and then you can get back to resloving the leaking hose or leaking vacuum valve for example
You will be establishing the parts of the CC that you will need to be replacing in the future at this same time

Enjoy

Thanks .  Just got done refinishing the valve.  No big deal.  Not very intimidating (once you've done it).  Thank for the advice.

RSS

Photos

  • Add Photos
  • View All

Forum

Power Steering Hose Nut

Started by Brian Pospichal in 1963/64 Cadillac Specific Discussion. Last reply by Chris Codd 53 minutes ago. 1 Reply

Any tips,tricks,suggestions on what's worked for you to loosen the 11/16 nut on the power steering high pressure hose? I can get a flare wrench on it but access is limited and awkward and t's hard to…Continue

Door lock vacuum

Started by Bill Hatfield in 1963/64 Cadillac Specific Discussion 1 hour ago. 0 Replies

Hey folks. First post. I hope I'm doing it right. I currently restoring a 1964 Fleetwood 60 series Special. There is an egg shaped vacuum canister on the left side of the firewall behind the tire. It…Continue

Re upholstering seats

Started by paul in Restoration Discussion. Last reply by Jason Edge 21 hours ago. 5 Replies

Hello all, my question pertains to interior of a recent barn find.  A 1963 cadillac sedan with 16000 original miles.  Unfortunately it had mice in the car, so of course the whole interior which is…Continue

Current 1963/64 Cadillac Listings on eBay

Started by Jason Edge in For Sale. Last reply by Jason Edge yesterday. 0 Replies

To see all 1963/64 Cadillacs Listed on eBay in the USA…Continue

Tags: ebay

Blog Posts

Is there a separate Starter Relay, or does the Solenoid serve that purpose?

Posted by Norman Silverman on August 30, 2019 at 5:57pm 7 Comments

Hello All.

I will be replacing the starter solenoid tomorrow (actually my mechanic will do the work, I'll just supervise). In checking the FSM electrical schematic and chapter verbiage, I don't see anything that looks like (or is referred to as) a starter Relay. It seems the Starter Solenoid serves the function and there's no separate relay. Right or Wrong?

If wrong, where…

Continue

Starter Solenoid replacement-how difficult? Where to buy?

Posted by Norman Silverman on August 20, 2019 at 8:24pm 8 Comments

Hello All.

I believe the starter solenoid has gone bad in my 64 DeVille. When I turn the key, often all I get is a click, then if I try a few times again the starter turns perfectly. All battery cables are on tight and the battery is good. So, I believe this problem is the solenoid. Where do I buy the right solenoid and is it necessary to remove the starter in order to swap it out? …

Continue

Frame Markings

Posted by Gene McIlroy on August 12, 2019 at 6:26pm 1 Comment

Just got my frame back from powder coating so thought I would post photos of the front and rear frame markings.…

Continue

Lining up the drive shaft

Posted by Dominic Salemi on August 12, 2019 at 5:47pm 2 Comments

Can anyone shed some light on how to position the complete drive shaft in the correct position? I want to make sure my drive shaft is installed properly.

Thanks

Dominic

Videos

  • Add Videos
  • View All

© 2019   Created by Jason Edge.   Powered by

Badges  |  Report an Issue  |  Terms of Service