So, i’ve Reached the blower motor on my list of things to fix.

the car doesn’t have A/C, the control has a switch that seems to control the variable can speed on the car.  This doesn’t work at all.  My fan currently has two speeds. On, or off.  It clicks on when the switch clicks into the highest setting.

also, the control arms for the temperature and heat/Defog/deice.  If I move them over to the far left the fan clicks off.

any suggestions? Could this be a faulty switch, faulty motor or the resistor packs?

Views: 170

Reply to This

Replies to This Discussion

Although I'm not familiar with the 63 system I would start with whatever is easiest to get at. If the fan works the resisters is a logical place to look. But if it goes to high speed only in heater mode I would think that defroster mode would also be high speed. That would lead me to think the board on the controls is either dirty or worn. I don't know exactly how your controls are set up, if it has a switch or copper contacts on the back I would check for continuity in all positions. If you don't have continuity in all positions then you may be able to clean it with some contact cleaner. 


The picture shows the style of control I have.  The two levers on the left control the fans that lead directly from outside.  The levers on the right control temperature (bottom) and whether the fans are set to heat, Defog or deice.

the switch at the top has three positions, off on the left to ‘high’ on the right and control the fan speed.

everything works as it should, except the blower motor on switches on when the switch at the top clicks into the fastest setting.  This happens no matter what setting I have the upper lever set to.

however, if I push both levers to the left position (as in pic), the fan switches off.

does that clarify my problem a little more? I haven’t removed or taken the switch out of the vehicle so don’t know how the contacts look

thisnis the first time I have ever tinkered with the heat on one of these cars so am going in blind and trying to take a common sense approach..

Thanks for that, really helpful.

i’m definitely Hearing a click when I move the lever from off to heat.

Is the resistor in the engine bay or behind the dash? I’ve traced a few wires from the blower motor and they seem to go to a bell shaped object just below the motor, is it in there?

Clovis
I just want to thank you for the great info you have brought to this site from day one
Your understanding of the 64 comfort control system ( which is crazy complicated ) is a blessing to any of us repairing that system
You have already earned your --ANGLE WINGS -the way i see it for all the great help you offer
We just can not have enough people with your god given talents around --
My friend

Enjoy

The picture you posted may be the off position for everything, blower included. Does the lever on the top right turn the blower on when it is under the heat position? I don't believe your blower should come on with the two left positions as that is your kick panel vents. 

Yeah, the two left levers don’t affect anything on the heater.

if I move the upper right lever to heat the blower does come on, but only if the switch at the very top is in the far right position.  If the switch at the very top is switched in any other position the fan does not come on, no matter what position the lever is in

James, on the heater control head, there are 2 switches. A fan speed switch and a master switch. With the ignition off, move the top right lever from off to heat. You should hear a click. That is the master switch, and its job is to send power to the blower switch.

With the ignition on, put the fan in the low setting (second detent) and put the lever to heat. Check the orange wire at the resistor connector. You should have power. If you do, then check for power going out of the resistor. If power goes out of the resistor, then the fan is bad, if power does not go out of the resistor, then the resistor is bad.

 If you do not have power to the resistor, then the fan switch is bad.  The light blue wire is for the medium fan speed, and the dark green is for the high setting.

https://youtu.be/6IcOzr7fCo4

hopefully this video shows the issue better than how I explain it.

I don't have a 63 shop manual so it one of two things, switch or resistors. The shop manual should tell you what the resistance should be for the resistors. If you can get your hand up behind the switch see if you can wiggle the connection, it may have a bit of corrosion preventing good contact. 

Here are a few pictures of the controls. 

Thank you so much for that! That’s brilliant.

i’ve had a wiggle behind the dash and everything seems pretty tight, so next is to buy a new resistor.

once again, thanks for our help. 

James I would test the resistors before going out and buying a new one. It still could be the switch or a tired blower motor that will only turn on high voltage. 

RSS

Photos

  • Add Photos
  • View All

Forum

Current 1963/64 Cadillac Listings on eBay

Started by Jason Edge in For Sale. Last reply by Jason Edge 13 hours ago. 0 Replies

To see all 1963/64 Cadillacs Listed on eBay in the USA…Continue

Tags: ebay

Extension Housing Hydramatic

Started by M123 in 1963/64 Cadillac Specific Discussion. Last reply by M123 yesterday. 1 Reply

Hi.Can you on a 64 remove the extension housing with the gearbox still in the car? The car have the Hydramatic.Did work on the car last night and did feel a very large play on the outgoing axle,…Continue

1965 Cadillac DeVille

Started by DanielAndrew in For Sale on Saturday. 0 Replies

1965 Cadillac DeVille On Ebayhttps://ebay.to/2W6axyTContinue

Trun signal swit

Started by Jeff S. in Wanted to Buy. Last reply by Charles Fares on Friday. 2 Replies

Hello all!Looking to either repair my existing turn signal switch or source a new one. Any suggestions?Thank you ub advance!Continue

Blog Posts

Cadillac Returns to its Roots Under New Leadership

Posted by Jeff Kinzler on May 1, 2019 at 12:30am 3 Comments

Cadillac’s new boss says they should stop trying to build BMWs and go back to building Cadillacs again.

What do you think? 

https://carbuzz.com/news/cadillac-finally-admits-what-everyone-knew-for-years

Radiator And Shrouds

Posted by Dominic Salemi on April 24, 2019 at 3:36pm 1 Comment

Hello

Anyone have a decent radiator and shrouds and hardware for a 1964 Cadillac deville. I have an alum. radiator and I'm deciding on to fix it or back to the original one. If I fix it I won't need parts.

Thanks

64 Recirc/Fresh Air Door Actuator replaced; FROM THE INSIDE.

Posted by Norman Silverman on February 4, 2019 at 11:21pm 8 Comments

I am happy to report that I have successfully replaced the Fresh Air/Recirc door actuator that is located on the blower box-and have done so without having to remove the blower box. I did it by taking out the glove box and attacking it from the back.  It took several days, LOTS of patience and some band-aids, but it is done. THE most difficult part -BY FAR- is to remove and then replace the screw that sits on the actuator arm, connecting it to the fresh…

Continue

Videos

  • Add Videos
  • View All

© 2019   Created by Jason Edge.   Powered by

Badges  |  Report an Issue  |  Terms of Service