So, having been through many installations of a new Edelbrock 1406 with no success getting it to run smoothly, as documented here, and THANKS for everyone's help, I ordered a rebuilt Carter AFB.

The original problem was that the Carter AFB installed on my '64 convertible needed 15 pumps to start and always felt starved for gas. Adjustments did not help so I went to Edelbrock, and with many problems, went back to Carter AFB. The Carter I installed has the car starting OK and running smoothly, but it dies on idle.

I turned the mixture screws to closed and opened them up 1 1/2 turns, and tried the center idle screw a couple of turns each way with no real improvement. I do have the metal shim on top of gasket-phenolic spacer-gasket then metal shim.

All vacuum lines(to brakes and distributor) seem connected properly, as before. Wonder what I'm missing here? Can't drive and test the car if it won't idle. Trying to get it to my mechanic for professional setup. May have to see if I can get him to my house but in neither the Edelbrock nor my old Carter AFB installation was idle a problem. Thanks again.

Preston in Darien, CT

Views: 130

Reply to This

Replies to This Discussion

It sounds to me like you need to increase the idle -- with the idle adjustment screw
Not the screws in front of the carb which should not be touched after being set once
With the car off -- get on the driver side of the car and remove the air cleaner
Grab the carb linkage and open the carb with the linkage to full open and hold it there
When you look down at the carb linkage you will be looking at a screw head Just inside the linkage
Turn the screw a half a turn-- put the air cleaner on and start the car to see if the idle has increased
It will at some point
You will need to repeat the above--with the car Off turning the screw a bit at a time until you get the car to run at idle
That should get it to hold an idle of some kind
When you put the car into gear it will drop the engines RPM so allow for that in your idle adjustment or you will stall the engine
Do not run to high an idle or stopping the car can get harder to do as the engine will be working against the trans to some degree
That should get you to your mechanic if required

Enjoy

Thank you, sir! Now, it would sound like you're talking about the fast idle screw. I know about that, and on my "new" rebuilt carb, it does not engage so far. I am looking to my mechanic to sort that out, he knows carbs. But I don't know that it will solve my prob, because cold or hot, I can get the thing to idle. However, I will go look at that screw and try some more. There are only two screws, the big center "idle speed screw" and the hidden, tucked-under "fast idle screw" which you can only reach by pushing hard on the mechanism to bring it up where you can reach it. 

Keep turning the screw on the linkage in ---until the car runs at an idle for you

Any adjustments on the screws on the front of the carb must be done on the proper guages ( or an air sensor ) only once when the carb is installed new after a very complete tune up ( including new wires ) to get the setting on the carb and tune perfect

Enjoy

Thanks, Tony...I got the car running on the rebuilt Carter AFB just enough to get to the mechanic, who specializes in older cars. He drives a Chevrolet Monte Carlo. I told him "make it work with the Carter or the Edelbrock 1406, I do not care, whatever provides the best result." He knows these carbs and has all the test equipment. I failed to install the Edelbrock, and the Carter was easier and "better" to me, but it wouldn't provide an idle, so it's in the hands of long experienced professionals now!  

All good
The point being to get the car running great - so you can Enjoy it as you SB

Enjoy

RSS

Photos

  • Add Photos
  • View All

Forum

Trivia Question 17 - Item You COULD NOT Delete Because of Cars Heater

Started by Jason Edge in Trivia. Last reply by Tony and Ginny 429 25 minutes ago. 6 Replies

OK. We had so much fun with the last Trivia regarding the car's heater, I thought we should post another heater related question.  So here goes:What item does the spec manual go out of its way to…Continue

Tags: Question, Trivia

Good Sources for Parts?

Started by Bob Ricks in 1963/64 Cadillac Specific Discussion. Last reply by Russ Austin 6 hours ago. 1 Reply

New member here so be patient with me.  New owner of what I would consider a rat-rod 63 caddy.  Previous owner painted everything flat black, in an obvious attempt in covering up body deficiencies. …Continue

Trivia Question 16 - Standard Item You could Delete for Reduced Cost?

Started by Jason Edge in Trivia. Last reply by Tony and Ginny 429 12 hours ago. 21 Replies

OK. Here's a new trivia. There is at least one main standard (non-option) item that one could "delete" on a new 1963 or 1964 Cadillac for a reduced cost.  What is it?  For extra cigars, what is the…Continue

Custom '64 Eldorado on Bitchin' Rides Last Night

Started by Ian Osborne in 1963/64 Cadillac Specific Discussion. Last reply by Cees de Bunje 21 hours ago. 1 Reply

If anyone here is familiar with the show "Bitchin' Rides" they started work on a '64 Eldo on the episode that aired last night (12/5). I really like the show and they build some amazing custom…Continue

Blog Posts

still need a driveshaft

Posted by wayne weaver on November 26, 2019 at 11:53am 2 Comments

well thank you UPS for losing the driveshaft that Russ Austin shipped me. 

however i still need a rear driveshaft section for my 63. mine has a vibration due to the bushing inside of it. its a shame because the ball and sockets in the cardian joints are perfect but it has a woble on the balancing machine. so .  still need the rear section. anyone have a good one ? is there driveshaft alternatives to use ? i am really considering an LS swap and since im fighting the driveshaft search…

Continue

63 guidematic issues

Posted by maurice lapoiinte on November 24, 2019 at 3:10pm 0 Comments

 So my 63 guide matic headlamps stay on low beam all the time. I have so far bypassed the system and everything works normal. I have been thru the trouble shooting in the manual but this is where the confusion begins.on my car when the power relay is powered I have low beam and when its not powered I have highbeam, this appears to be opposite what the diagnosis says should be correct.The wiring is all original and no wires have been mixed up.has anyone ever unplugged the 2 wire connector…

Continue

Another advantage of the Pertronix III

Posted by Doug Scarrow on November 23, 2019 at 11:12am 1 Comment

   Having tried both the II and III I can say the multispark feature of the III offers a smoother idle . It is also easier to install .Does not require removal of the distributor

Stuck at two red (dash) lights!

Posted by Jeff Kinzler on November 3, 2019 at 10:00pm 9 Comments

I hope someone can help solve these two electrical problems that appeared one after the other.

By way of background: The car, a '64 Eldorado has very limited use. It was at a restoration shop for 15 months until last January-  that supposedly did a bunch of wiring repairs including rebuilding the gas gauge that still hasn't worked properly, and the clock that hasn't worked, and re-soldering the broken wires in the drive door. All window and seat controls appear to be…

Continue

Videos

  • Add Videos
  • View All

© 2019   Created by Jason Edge.   Powered by

Badges  |  Report an Issue  |  Terms of Service