18 years back and many miles since, I replaced the Factory original Mode Actuator and heater core. Well, a couple of weeks back the replacement Mode Actuator failed. I ordered a new Actuator from Old Air Products. I figured even though the Heater core was still good, not leaking, I might as well replace it while I had everything apart. I ordered the new heater core from Rock Auto. I have the Heater Box assembled but I haven't installed it under the dash, yet. For anyone interested, I uploaded to my page, some pictures of the Heater Box, etc. I was able to remove the Heater Box from under the dash without removing the blower housing from the engine bay firewall or removing the hood hinge, as the shop manual lists to do.

Views: 268

Reply to This

Replies to This Discussion

David 

Nice work on the 63 Ac heat box and  the fuel pump 

You got me thinking ( reminding me ) about jumping into  doing my 64 comfort control which I have purchased all the parts for a short while ago 

Been to hot in Florida but the weather will be getting real sweet very soon 

I  realize I am hung up on what to do about removing  the passenger hood hinge to get the project started as I do need to get into the blower box myself 

That engine hood is a serious heavy weight item to be dealing with 

Most of all I miss  not having my heater working for those —brisk very cool  nights  coming home from a day out with the top down

The 429 buts out enough heat when called on  to heat a small apartment building —LOL !

Always enough heat to keep the front seat extremely comfortable with the top down 

I seldom use the AC because the top is always down but I still need to have it working correctly in my pride and joy 

Enjoy 

Hi Tony, thanks for the kind words. As Russ and I stated, no need to remove the hood or hinge to get the under dash ductwork out. There are 6 speed nuts securing the duct to the firewall. All can be removed with a deep well  1/4 inch drive socket and long extensions and a universal joint. The nut under the hinge area will require a little fanagling, but it is doable.

The Airtex fuel pump failed at 15k miles. It spit the intake valve out. As you can see in the picture,  it was not staked in at the factory. 

Understood about getting the under dash air box out with the  passenger hinge  in place 

Can the blower motor box and the evaporator with the suction valve ( on the inner fender ) be remove as well with the hinge in place even if it takes a bit more effort doing it that way ? 

I do have a 64 with comfort control so the 63 SB a bit different design than mine 

Enjoy 

On the 63, I think the blower housing could be removed after removing the heater box without having to remove the hinge. I've never removed the evaporator,  but would think it would then be removed following the shop manual steps.

David 

Removing the under dash air box and then the blower box sounds like a good plan 

With the blower box out should be easier to get to the evaporator out  to check it’s condition 

Working around the hinge looks like a good plan  from the posts here 

Enjoy 

David 

It is possible to epoxy glue the valve in the fuel pump to hold it in place permanently 

Epoxy is gasoline proof and I have repaired fuel pumps in the past with it that held up for the very long haul 

i clean the surface with 91 % alcohol first 

Just another way to get that repaired done to last 

Hard to believe the valve was never installed correctly by the manufacture so most should pass on the Airtech  brand unless they choose to do this repair before installing the fuel pump into the car now being aware of the problem with the brand 

 The  Airtech fuel pumps are short lived as a rule due to  the manufacturers oversight if the problem is not addressed 

Russ was the first one I remember  to bring this to the attention of the community 

Enjoy 

I'm still chasing vacuum leaks on the 63 A/C system.  Trying to remove the A/C control switch panel so I can check the vacuum switch. The shop manual says after unbolting and disconnecting the switch assembly, to remove it from the dash.  I haven't been able to thread it out of the dash going up or down. Has anyone had success, what am I  missing? Thanks.

I remove them with the entire dash out so that will not help you but looking at the 63 & 64 shop manuals, the 63 say to disconnect the left AC outlet hose (note 15.a pg 15-9), and of course on note 14a. you have a series of disconnects such as Bowden cables, etcs. and assume hall have been disconnected, lower instrument (dash) panel removed etc. The other thing I noticed is the 64 shop manual did say to bring it out from the top ... but the 64's other than the series 75, have a different shaped, upper steering column hanger bracket, so that might be why the difference. Regardless, it will probably just take a good light and some patience and be ready to temporarily disconnect or move things. It is busy back behind there. 

Thanks Jason.  The path looked better going out the top but I couldn't get it past the speedometer and upper cowl. I became frustrated after about an hour of twisting and turning it all around and decided to call it a day. I'll go back at it in a day or so to see if I can get it to cooperate. Maybe someone else has been there and can give us some pointers on getting it removed.

Move the fuse box out of the way. 

Thanks Russ. I suspected that you or Jason had been there before. I'll try that when I get back to it.

 I was able to get the A/C control panel out this morning. As Jason suggest from the 64 shop manual it came out the top. I did have to remove the headlight switch to get clearance and even then it was tight. I tried moving the fuse panel as Russ suggested but that didn't work out.

Is there a way to restore the A/C 6 port vacuum switch? Are there sources for new replacements? The one in my 63 seems to have a good amount of seepage to it. The 3 port heat control switch seeps a little, but not as much as the 6 port.

After removing the headlight switch I noticed the Ceramic around the dash light resistor was broken. Can that be repaired with JB weld or something similar? It is in two pieces held together by the resistor wire.

RSS

Photos

  • Add Photos
  • View All

Forum

63 coupedebille fuel pump issues

Started by Daniel Grande in 1963/64 Cadillac Specific Discussion. Last reply by Tony and Ginny 429 4 hours ago. 20 Replies

I have a 63 cadillac and I took it to a mechanic for a motor tune up long story short the fuel pump gave out and hes tried twice to order it and he says it didnt fit the original pump is smaller on…Continue

A Before & After Example

Started by Jason Edge in Restoration Discussion yesterday. 0 Replies

Since I started cadmium plating the many fasteners and other items from the 55 and counting parts cars I have bought in (1200 lbs worth and counting), I have to say it has really taken the…Continue

Oil leaking out of oil cap breather

Started by mark zimmerman in Restoration Discussion. Last reply by mark zimmerman yesterday. 12 Replies

Hi i would like some ideas on this i replaced oil cap breather and pcv valve and still oil  coming out of breather at normal speeds down the road.This has been going on for quiet awhile from the…Continue

Update on fuel pump

Started by Daniel Grande in 1963/64 Cadillac Specific Discussion. Last reply by William R Conte yesterday. 1 Reply

I'm still looking thru land and sea for this fuel pump anyone out there know what size engine I have here are some pics of the stamps on the block I found to make sure my engine is a 390 because the…Continue

Blog Posts

1963 series 62 convertible transmission issue

Posted by Matthew VanDeWater on June 22, 2021 at 3:03pm 1 Comment

Hello I've been restoring a 63 for way to many years. Down to almost done, but have issue with trans linkage, when column in park shift rod 2 inches short. everything original. been trying to find picture of manual rod hooked up from under car to see position of linkage. was wondering if anybody has access for pictures. I wanted to see if my manual linkage is bent  wrong out of the trans if somebody dropped the trans or something. Doesn't make sense why it doesn't work. Thanks for any input…

Continue

New vehicle in the club

Posted by Patrick Westphal on June 17, 2021 at 4:00pm 1 Comment

I was successful in getting a vehicle from the New York contact I talked about at the last club meeting. I am still trying to figure out how to post a picture of the vehicle that is tied with this comment so if you see a random picture of a black convertible in a yard, that's me haha.  …

Continue

Torque converter grab when idling in Drive

Posted by Cliff Johnston on June 14, 2021 at 8:47pm 2 Comments

Hi Everyone, been quite a while since i have been on here.

I have had an issue with the idle on my 64 Coupe Deville ever since i have had it.

With the Idle set high enough that it is smooth, but still a nice idle, the RPM seems only slightly too high for the stall of the Torque Converter. And therefore it tends to sit there and grab and lunge a bit. So until now, i have been putting the car in Neutral at the lights to stop this happening.

I've had the car dyno tuned and…

Continue

Can you help? Driveshaft Question....

Posted by Chris on May 30, 2021 at 8:55am 1 Comment

Hello!

Newbie to the group here - we have already found tons of invaluable information on the board, so thanks! We are restoring a 1963 Series 62 Convertible. We are wondering if anyone knows of a source to buy the propellor yoke flange (that bolts to the pinion flange) for the driveshaft? One of our ears partially broke off. Not sure if we can buy just the yoke flange as an aftermarket part, or if it has to be rebuilt by a welder/fab guy? Maybe a salvage yard for a source? Again, any…

Continue

Videos

  • Add Videos
  • View All

© 2021   Created by Jason Edge.   Powered by

Badges  |  Report an Issue  |  Terms of Service