more electrical issues

when I mounted the headlights, both low beams lights worked

the high beams did not

i replaced the pax side high beam and at that point, the low beams and the pax high beam worked, drivers high beam did not

i checked drivers high beam continuity and it failed. I replaced the drivers side high beam

now with low beams on, only the pax side works

with high beam selected, the high beams both work and the drivers side low beam work

the pax side low beam does not 

could this be a light issue? 

Tired of chasing my tail on these.....

HELP!

Views: 134

Reply to This

Replies to This Discussion

My headlight issues turned out to be caused by an internally corroded high beam switch. After taking the switch apart and cleaning it everything was working properly again.

My switch was working fine prior

i doubt it is a ground as the high beams wouldn’t work either

Before you chase wiring I would check each light bulb individually with a 12 volt source.  If I am reading your post correctly, then if the RH passenger Lo Beam coincidentally burned out, it would give you this symptom?  Always check the bulbs 1st.
Also, the outer headlights are Hi & Lo Beam double filament bulbs, so make sure you are testing both the Lo beam and Hi beam filaments.  There are 3 male tabs so you have to alternate between the 3 tabs to test Hi and Lo Beam.

If lights are flickering then I would suggest checking the black ground wire of the forward lamp harness just forward of the radiator core support, but this sounds like either burnt bulb filament(s), bad connection, or wiring... but since RH lo beam was working I would look at burnt filament or bad connection 1st. 

Thx again for all the suggestions

apparently, the 63 Cadillac is a bit temperamental WRT battery strength

my power seats were not moving......the motor was on, and I heard clicking.....and he headlights were acting up.

i replaced one low beam bulb and had the battery tested.....it failed.

i put the new battery in and presto......power seat is moving fwd and aft, and it tilts ......I still heard clicking, but will check this out later.

the new headlight works great...am replacing the other tomorrow

have a great weekent

RSS

Photos

  • Add Photos
  • View All

Forum

Rear Wheel Bearings Replacement

Started by Dominic Salemi in 1963/64 Cadillac Specific Discussion 27 minutes ago. 0 Replies

HiNeed to replace my rear wheel bearing and seal on my 1964 Conv., does anyone know if its a big project and what I will need before I pull the shaft out? I also need to know the parts number and…Continue

Winter time cruise in Australia.

Started by Kevin Campbell in General Discussion. Last reply by Kevin Campbell 32 minutes ago. 4 Replies

The weather here in winter is great for a Cadillac cruise.Continue

looking for a 429 heat riser and cruise control unit

Started by Christian Doerk in Wanted to Buy. Last reply by Kurt 1 hour ago. 1 Reply

I am looking for a functioning heat riser valve and a cruise control for a 1964 Cadillac.In principle, the heat riser flap does not have to work. It is only important that the spacer / housing is not…Continue

Tags: exhaust, riser, heat, control, cruise

Current 1963/64 Cadillac Listings on eBay

Started by Jason Edge in For Sale. Last reply by Jason Edge 3 hours ago. 1 Reply

To see all 1963/64 Cadillacs Listed on eBay in the USA…Continue

Tags: ebay

Blog Posts

64 Power Servo vacuum leak

Posted by Kent Prows on June 27, 2020 at 4:02pm 0 Comments

I finally got around to fixing a leak in my heater core.  I decided to check to see if there were any other obvious issues while I had everything torn apart.  When I put a vacuum directly (bypassing the transducer) to the power servo it gets to about 10" and then slowly leaks back to zero.  The fan will not go to full and the mode door will not open completely.  I have read a couple of other posts that said they repaired the power servo leaks.  How?  Does anyone have one to sell?  I just…

Continue

63 Caddy Horn

Posted by Robert Alan Shannon on May 27, 2020 at 9:25am 9 Comments

 Just noticed a 1963  Caddy trumpet horn on Ebay. No part # given but some of his other items are 1963 specific, just throwin this out there, I have no connection to this listing .

Wiring connection help.

Posted by Jimmy Davis on May 24, 2020 at 9:15pm 2 Comments

Can someone help me figure where these connections go? I have a 64 60 special if it matters.…



Continue

Wood grain finally done.

Posted by Jimmy Davis on May 20, 2020 at 4:57pm 3 Comments

After years of wanting to, I finally redid my wood dash paneling on my 64 60s. Not too hard to do either.…

Continue

Videos

  • Add Videos
  • View All

© 2020   Created by Jason Edge.   Powered by

Badges  |  Report an Issue  |  Terms of Service