Anyone install better quality intake manifold gaskets?

Views: 584

Reply to This

Replies to This Discussion

Joe I ordered a set of mahal(?) intake gaskets off rock auto and they were metal. I wanted composet material so I ordered felpro. Guess what... They were the same LOL. I used a very thin layer of high temp gasket sealer on both sides before installing them and haven't had any problems. I also made metal shims to block off the exhaust cross overs while I had it off. My car will never be driven in the winter again.

Do you think a leak could have developed because I was running lean ? this is the second set I have had to replace since the motor got rebuilt about two years ago.

There is Best Gaskets and Olsons Gaskets. I know Olsons is a thick non metal material. They have the gasket with the exh port blocked off also, but it needs a backer as it will burn through.

Hey Sugar

What is it that makes you think the gasket has gone bad again ?

Very odd for your intake gaskets to be so short lived
Especially twice
I would question the installation procedure and use a highly recommended gasket from Jason or Russ this next time around
A sealent is sometimes required in the gaskets corners
Look over the service manual on the subject if you are doing the job

I do not think that a lean engine would be the cause of your intake issues
It just makes the engine run on the hot side and heat is the oils enemy ( brakes it down )

Enjoy
Thank you Tony.
I have never installed intake manifold gaskets before, I would appreciate if anyone could tell me what all I need before I start so I can complete it in one shot, and we're in the shop manual it tells you any information on intake manifold? I've looked and can't find it anywhere

Intake installation is on page 9-17 in the 1964 Cadillac Shop Manual.

Your very welcome -- Joe

Enjoy
Joe there isn't any information on the intake in the shop manual. I used the WAG method for the torque sequence when I reinstalled mine. Why do you think your gaskets are leaking? And why do you think it was running lean?

I think it was running lean because my spark plugs were white & it was idling low with the AC on, as we have learned. I think I have an intake manifold leak because I can hear it under load

page 9-17

hat is the WAG method ?

RSS

Photos

  • Add Photos
  • View All

Forum

Custom '64 Eldorado on Bitchin' Rides Last Night

Started by Ian Osborne in 1963/64 Cadillac Specific Discussion. Last reply by Cees de Bunje 6 hours ago. 1 Reply

If anyone here is familiar with the show "Bitchin' Rides" they started work on a '64 Eldo on the episode that aired last night (12/5). I really like the show and they build some amazing custom…Continue

Trivia Question 16 - Standard Item You could Delete for Reduced Cost?

Started by Jason Edge in Trivia. Last reply by Kevin Campbell 6 hours ago. 17 Replies

OK. Here's a new trivia. There is at least one main standard (non-option) item that one could "delete" on a new 1963 or 1964 Cadillac for a reduced cost.  What is it?  For extra cigars, what is the…Continue

1963/64 Cadillac Chapter December 2019 Newsletter Posted

Started by Jason Edge in Newsletters yesterday. 0 Replies

I have just completed and posted the December 2019, 1963/64 Cadillac Chapter Newsletter to our…Continue

Tags: Newsletter, Chapter, 2019, December

Current 1963/64 Cadillac Listings on eBay

Started by Jason Edge in For Sale. Last reply by Jason Edge yesterday. 1 Reply

To see all 1963/64 Cadillacs Listed on eBay in the USA…Continue

Tags: ebay

Blog Posts

still need a driveshaft

Posted by wayne weaver on November 26, 2019 at 11:53am 2 Comments

well thank you UPS for losing the driveshaft that Russ Austin shipped me. 

however i still need a rear driveshaft section for my 63. mine has a vibration due to the bushing inside of it. its a shame because the ball and sockets in the cardian joints are perfect but it has a woble on the balancing machine. so .  still need the rear section. anyone have a good one ? is there driveshaft alternatives to use ? i am really considering an LS swap and since im fighting the driveshaft search…

Continue

63 guidematic issues

Posted by maurice lapoiinte on November 24, 2019 at 3:10pm 0 Comments

 So my 63 guide matic headlamps stay on low beam all the time. I have so far bypassed the system and everything works normal. I have been thru the trouble shooting in the manual but this is where the confusion begins.on my car when the power relay is powered I have low beam and when its not powered I have highbeam, this appears to be opposite what the diagnosis says should be correct.The wiring is all original and no wires have been mixed up.has anyone ever unplugged the 2 wire connector…

Continue

Another advantage of the Pertronix III

Posted by Doug Scarrow on November 23, 2019 at 11:12am 1 Comment

   Having tried both the II and III I can say the multispark feature of the III offers a smoother idle . It is also easier to install .Does not require removal of the distributor

Stuck at two red (dash) lights!

Posted by Jeff Kinzler on November 3, 2019 at 10:00pm 9 Comments

I hope someone can help solve these two electrical problems that appeared one after the other.

By way of background: The car, a '64 Eldorado has very limited use. It was at a restoration shop for 15 months until last January-  that supposedly did a bunch of wiring repairs including rebuilding the gas gauge that still hasn't worked properly, and the clock that hasn't worked, and re-soldering the broken wires in the drive door. All window and seat controls appear to be…

Continue

Videos

  • Add Videos
  • View All

© 2019   Created by Jason Edge.   Powered by

Badges  |  Report an Issue  |  Terms of Service