Hello everyone. It's been a while since I posted here and I hope all is well with everyone and they had a good winter. I can't remember who it is but I know there's an Australian in here too, so I hope they had a good Summer.

The other night I was driving around and found a new issue with the Cadillac. When the high beams are on, after a few minutes they go off. In fact, they end up blacking out all lights on the car. After a few seconds, they all come back on. Then this cycle repeats indefinitely. It doesn't seem to happen with just the regular lights on, so I'm guessing something is getting over loaded, or something is weak in the system. My initial thought is the headlight switch/relay in the dash.

Anyone run across this before and maybe have an idea how to trouble shoot it? Thanks in advance as always.

--Jake

Views: 298

Reply to This

Replies to This Discussion

Kevin

We use to pull off the top of our Carter carbs to rejet the carbs during time trials at the track ( i had a two four barrel set up )
No time to be wondering where your balls are in that case --LOL
We would pick up a car or two at the drags when we got the jetting right for the days weather
Thought you might enjoy that from one drag racer to another while on the carb rebuild parts all over the place ---subject

Enjoy

Russ
Enjoyed the shoe box ( flying parts under control idea )

Enjoy

For the time being, the car wins.  Russ, I will be sending you an email to get one of those harnesses from you.  I still have a feeling it is in the switch and will be sending it out to get it rebuilt.  However, I learned my lesson last year that I try to not send things out to get them fixed during the driving season since, well, it limits my time with the car.  I will be waiting until winter hits to send out the switch.  In the meantime, Russ, you have an order coming your way..........

Just to close this one out.  The harness from Russ has been installed.  The drama with the headlights is gone.  Pretty sure the problem is the headlight switch is weak. Thanks as always, Russ.  The led tail lights I ordered from you should be delivered tomorrow.

I'm a fan of keeping these things original, but with the break lights being as soon as they are and a lack of head rests, I figure the led tail light upgrade might reduce my chances of getting rear ended.

--Jake

RSS

Photos

  • Add Photos
  • View All

Forum

Is this possible or total BS?

Started by Kim K Kaiser in 1963/64 Cadillac Specific Discussion. Last reply by Tony and Ginny 429 6 hours ago. 5 Replies

After changing tie rods, i tokk car into wheel n allignment shop. He said no problem.  He calls back about 45 minutes later and said they couldnt get between the tire and cowl, the guys head was too…Continue

Vacuum / Parking Brake / NSS Question

Started by Karl Schwarz in 1963/64 Cadillac Specific Discussion. Last reply by Karl Schwarz 7 hours ago. 2 Replies

I bought a 1963 Series 62 Convertible in July.It makes a hissing sound when in neutral, and sometimes when in drive (when the shift is more to the left that the right. I assume this related to a NSS…Continue

Tail pipe black stuff!

Started by Lambert Ross in 1963/64 Cadillac Specific Discussion. Last reply by Lambert Ross yesterday. 10 Replies

any ideas how to clear the ugly black stuff shooting out from my tailpipe? After a long layover, it really messes up the garage floor. I assume its carbon but am not sure how best to react to it.…Continue

Blog Posts

still need a driveshaft

Posted by wayne weaver on November 26, 2019 at 11:53am 0 Comments

well thank you UPS for losing the driveshaft that Russ Austin shipped me. 

however i still need a rear driveshaft section for my 63. mine has a vibration due to the bushing inside of it. its a shame because the ball and sockets in the cardian joints are perfect but it has a woble on the balancing machine. so .  still need the rear section. anyone have a good one ? is there driveshaft alternatives to use ? i am really considering an LS swap and since im fighting the driveshaft search…

Continue

63 guidematic issues

Posted by maurice lapoiinte on November 24, 2019 at 3:10pm 0 Comments

 So my 63 guide matic headlamps stay on low beam all the time. I have so far bypassed the system and everything works normal. I have been thru the trouble shooting in the manual but this is where the confusion begins.on my car when the power relay is powered I have low beam and when its not powered I have highbeam, this appears to be opposite what the diagnosis says should be correct.The wiring is all original and no wires have been mixed up.has anyone ever unplugged the 2 wire connector…

Continue

Another advantage of the Pertronix III

Posted by Doug Scarrow on November 23, 2019 at 11:12am 1 Comment

   Having tried both the II and III I can say the multispark feature of the III offers a smoother idle . It is also easier to install .Does not require removal of the distributor

Stuck at two red (dash) lights!

Posted by Jeff Kinzler on November 3, 2019 at 10:00pm 9 Comments

I hope someone can help solve these two electrical problems that appeared one after the other.

By way of background: The car, a '64 Eldorado has very limited use. It was at a restoration shop for 15 months until last January-  that supposedly did a bunch of wiring repairs including rebuilding the gas gauge that still hasn't worked properly, and the clock that hasn't worked, and re-soldering the broken wires in the drive door. All window and seat controls appear to be…

Continue

Videos

  • Add Videos
  • View All

© 2019   Created by Jason Edge.   Powered by

Badges  |  Report an Issue  |  Terms of Service