On Friday I did install power antenna.When I try to raise the mast by pulling knob on the radio -mast didn't go up.I heard strong antenna motor clicking.I try to pull with plyers top of the mast and I realized that mast is going down while pulling  radio knob.Looks like antenna works when going down but not going up.What is the problem?What I did wrong.I did replace cable connecting radio with antenna.I did connect blue wire with blue and green with green wire.Before restoration antenna was working fine.Maybe the knob on the radio that control antenna have something to do it? I did lubricate mast with WD-40.

Thank you,

Paul

Views: 54

Reply to This

Replies to This Discussion

what happens when you push the radio knob rather than pulling it?

It is only react when I pull up.

put a test light on the green wire while somebody pushes the knob, if it gets power, replace the antenna motor. if it doesn't then it is likely the switch inside the radio.   could also be a broken green/white wire or bad connection at the firewall.

Pushing the  radio nob in should raise the antenna when it is working correctly 

I do think your new antenna motor is your issue 

Motor needs to be working in both directions 

Do be very sure your ground connection is cleaned and shinny metal but the motor is working —only not  in both directions 

The clicking sound is normal when the antenna is all the way down 

Enjoy 

The antenna is original from the car -not new.Maybe the radio knob I installed differently-because when I pull out the knob I have feeling like the antenna want to go down (it is already down).

  "It is only react when I pull up."   What does that mean?  Are you pushing the radio knob in?  The knob is designed to push in and pull out to raise and lower the antenna.  Check the wire connector for a pin that has pushed out. The plastic connectors get weak and brittle from being exposed to the elements. It has happened to me before, that a pin pushed out of the connector when they were mated together.

Push nob —is up 

Pull nob —is down 

Enjoy 

- Did you bench test antenna before installing? 12 volts to green pushes out, 12 volts to blue pulls in. If not, you can disconnect antenna connector at bottom right of firewall cowl and test via a 12 volt source to green then blue wire with antenna in car.

- Are you firmly pushing radio knob in? It takes some effort. Might take some tuner lube cleaner like the CRC sprays and push and pull the knob back and forth. If it is not pushing in and a spring action felt to push it back out something might be broken on the radio knob switch.

- Is knob correctly installed on shaft at the normal detente position with the Allen set screw?

- Is the connector at bottom right of cowl/firewall making good contact. Did you clean the metal inside the connectors to makes sure they make solid contact. It sounds like you spliced some wires... did you make sure everything was making good contact? 

- And as noted previously, you can disconnect the antenna connector and test for 12 volts on the car side connector for 12 volts at green when pushing knob in, and 12 volts at blue when pulling knob out. 

If you are pulling on the nob and the antenna is already down it is working correctly. ( on that side )  and will make a clicking sound when bottomed out 

you need to get the motor to rise —when you push in the nob 

Marks suggestions should help find the electrical issue and get the motor working correctly 

Clean the mounting locations  as they are the electrical grounds so clean them to shiny metal as that will make for good electrical flow to the antenna  motor 

Enjoy 

Ok,problem solved.

When I installed the knobs on the radio I push the top knob too far and didn't let me use the function to push antenna up.

Thank you for all suggestions.

Yep, just got to let the knob set at that "detente" position when setting the Allen screw.  Glad you figured it out!

Jason 

Really nice job realizing the nob  location issue was the problem 

Where else could you ever get this kind of  spot on repair info for such a specific  unique repair 

This place  and the individuals ( you know who you are )  here are just the best for this type info ( repair ) for our year cars that is so very specific to just our year Cadillacs 

Liked watching this difficult problem getting worked threw myself 

Enjoy

RSS

Photos

  • Add Photos
  • View All

Forum

Rear glass

Started by David Stapp in 1963/64 Cadillac Specific Discussion. Last reply by David Stapp 6 minutes ago. 10 Replies

anyone know of a company that makes the rear glass for our cars? I can’t seem to find any. 1964 4 door 4 window hard top.…Continue

Where can I buy resistance wire for my 1963?

Started by Tim Walterson in 1963/64 Cadillac Specific Discussion. Last reply by Tim Walterson 9 minutes ago. 4 Replies

Hello - just signed up for this forum - looks like a great resource!  I perused the posts and did some searches.  I see most of the posts related to my questions are about doing away with resistance…Continue

front engine pulley removal

Started by tom servas in 1963/64 Cadillac Specific Discussion. Last reply by tom servas 10 hours ago. 7 Replies

Am removing the front cover on our 64 engine with AC. Have all 6 bolts that hold the pulley onto the damper removed, can wiggle the pulley BUT it will not come fully off the damper, Is there…Continue

Blog Posts

Is there a separate Starter Relay, or does the Solenoid serve that purpose?

Posted by Norman Silverman on August 30, 2019 at 5:57pm 7 Comments

Hello All.

I will be replacing the starter solenoid tomorrow (actually my mechanic will do the work, I'll just supervise). In checking the FSM electrical schematic and chapter verbiage, I don't see anything that looks like (or is referred to as) a starter Relay. It seems the Starter Solenoid serves the function and there's no separate relay. Right or Wrong?

If wrong, where…

Continue

Starter Solenoid replacement-how difficult? Where to buy?

Posted by Norman Silverman on August 20, 2019 at 8:24pm 8 Comments

Hello All.

I believe the starter solenoid has gone bad in my 64 DeVille. When I turn the key, often all I get is a click, then if I try a few times again the starter turns perfectly. All battery cables are on tight and the battery is good. So, I believe this problem is the solenoid. Where do I buy the right solenoid and is it necessary to remove the starter in order to swap it out? …

Continue

Frame Markings

Posted by Gene McIlroy on August 12, 2019 at 6:26pm 1 Comment

Just got my frame back from powder coating so thought I would post photos of the front and rear frame markings.…

Continue

Lining up the drive shaft

Posted by Dominic Salemi on August 12, 2019 at 5:47pm 2 Comments

Can anyone shed some light on how to position the complete drive shaft in the correct position? I want to make sure my drive shaft is installed properly.

Thanks

Dominic

Videos

  • Add Videos
  • View All

© 2019   Created by Jason Edge.   Powered by

Badges  |  Report an Issue  |  Terms of Service