I have now ordered the replaceent compressor,,, the low energy, higher efficiency unit.  I am just assuming its already made for the r134.  Per  Michael Fortes fine write up, I also ordered the two big hoses, the dryer, the 90 degree connectors and the STV kit.

My question, after reading seveeral strings on this site regarding ac things,  Since the new compressor is a drop in replacemnet for the old compressor, and is supposed to be built for for r134, I started second guessing what i needed to do about the stv kit,  Now Michael got a rebuilt a6, so it was a r12, he had to change his out (stv), and the replacement i purchased is supposedly already built for r134, so do I need to do the stv change per directions supplied by Michael..

i dont want to fool with someting if i dont need to, but i have it coming anyway, it ws just second guessing after reading other articles that got me to overthinking,, 

Views: 42

Reply to This

Replies to This Discussion

Kim

You will need the correct oil to add to your compressor for the 134r

Get a set of washers for the hoses

You need the STV valve for the 134r

A set of AC gauges will get you the correct pressure readings — using a Chart— for the temp and humidity conditions at the time you are charging your system will give you the correct numbers you want at that time

Enjoy

Ok.    If i am pulling all these hoses oof and replacing, does it still need to be drained of freon,  or shoukd that be done up front?

Kim

It should be done first  —-by law due to its effect on our air quality

SB removed and put into a correct container 

Called evacuating the freon required by the shops that do a lot of AC stuff

Your call as to what you do

Enjoy

Ok.   Didnt know the order of evac.  Thanks


A vacuum ( to perg the system )  goes on to the system for a while to test for air leaks before you install the freon after the repairs are installed

Enjoy

so i do need to get a small vaccum pump after all the parts are put back together?  i was wathcing a utube video by eric the car guy,, and he hooked one up, to test for overnight, but that is not the same as pulling out the old freon,, correct.??

Correct

Freon removal first 

vacuum done later

RSS

Photos

  • Add Photos
  • View All

Forum

Radio restoration

Started by Joe DiIaconi in 1963/64 Cadillac Specific Discussion 1 hour ago. 0 Replies

I had my 1964 radio restored a few years ago and now it's not working correctly. Can anyone recommend a reputable place to have it restored again?Continue

Current 1963/64 Cadillac Listings on eBay

Started by Jason Edge in For Sale. Last reply by Jason Edge 10 hours ago. 0 Replies

To see all 1963/64 Cadillacs Listed on eBay in the USA…Continue

Tags: ebay

Grandpa’s Cadillac Restoration

Started by Jordan Johansen-Moe in 1963/64 Cadillac Specific Discussion. Last reply by Tony and Ginny 429 21 hours ago. 13 Replies

Hello friends! It’s been a while since I’ve visited this page. Last I left I had spoke about my late grandpa’s Cadillac that I planned on “restoring”, which really meant getting back on the road.…Continue

Crankshaft - ‘64 Sedan Deville

Started by Jordan Johansen-Moe in Wanted to Buy. Last reply by Jason Edge yesterday. 1 Reply

Hello friends! I’m looking for a crankshaft for a 429 that will begin Grandpa’s Cadillac Restoration. I will be talking to a machine shop on Monday (fingers crossed). However, in the event I hear the…Continue

Blog Posts

1964 Cadillac Fleetwood sixty special / transmission dipstick needed

Posted by Pablo on September 20, 2020 at 9:57pm 1 Comment

How are you doing folks, I’m looking for a transmission dipstick, any info I will appreciated, thank you very much

1963 Cadillac hood driver side hinge

Posted by Steven on September 16, 2020 at 9:23am 1 Comment

Hello,

 Does anyone know were I can buy a 1963 Cadillac hood driver side hinge or is there any other hinge that would fit? 

Thanks

Steven

Bad Guage?

Posted by Karl Schwarz on August 26, 2020 at 3:08pm 5 Comments

So I am troubleshooting my fuel gauge issue. I bought a new sender and tested it. It  it goes from 1-ohm (empty) to 35-ohm (full). When I test it (outside the tank), when the float is in the up (full) position it only moves the gauge to about 1/2 full. When at the bottom (empty) position the gauge shows empty. This is the same issue I have when I fill and then use the gas in the tank - the gauge never reads ore than half full. Based on what I've read on this thread it would seem like the…

Continue

Website

Posted by Fritz Seitz on August 11, 2020 at 2:35am 0 Comments

I have been working on a website-----www.fritzsautorepair.com-----

Does anyone have suggestions?

Videos

  • Add Videos
  • View All

© 2020   Created by Jason Edge.   Powered by

Badges  |  Report an Issue  |  Terms of Service