I have a 64 coupe with the original 429. It runs great, until you try to really accelerate then it pings and i'm hesitant to accelerate. The highest octane fuel we have here in California is 91. The owners manual says to use a minimum of 100 octane. That's not that easy (or cheap) to buy these days, at least not here. Does anyone use an octane booster? Do they really work? Any other suggestions? 

Views: 102

Reply to This

Replies to This Discussion

91 would be equivalent to the old 100. There are two different ways that they measured the octane rating. Today is only one accepted method. If you have pinging then you have other problems. I would check that vacuum advance is working and holding a vacuum and timing. Also do a tune up, cap rotor and plugs, if you dont know the age of them. Do you have points or petronix ignition? 

All those parts are new and the car is tuned to the factory specs. 91 and 100 octane are definitely not the same. 91 octane (R+M/2) and 100 octane (research method) are different, by I believe 11 octane as the research method 100 octane fuel has a motor octane rating of 104 (100+104/2+ = 102). Yes, 100 (RON) octane used to be the "premium" fuel with the highest octane and now 91 is considered the "premium fuel with higher octane but 91 octane is 91 octane. The car needs 100 octane (research method as described in the owners manual). It's a fuel problem, that I know. I'm just curious how everyone else is getting around it. Octane booster, expensive 100 octane race gas, or de-tuning  the car? Rebuilt engine with lowered compression? 

I wasn't clear enough I guess. No one else is reporting problems with 91 octane fuel. I definantly don't have problems with 91 and I am running 10 degrees on my initial. This is why I suggested that the problem is else' where. How is the oil consumption? Are you using the same company's 91 or have you tried other companies? These are the only suggestions I have as this is not a common problem with this engine running 91. The fuel in 1964 was no where near as good as it is today. Octane or not, it is consistent in its quality. In 64 not so much. Modern engines and their emissions related equipment need consistent and better fuel. Just my two worthless cents, good luck. 

I'm able get 91, 95 or 98 octane and I use 95.

I'm not that sure however, that octane ratings are worked out the same way the world over.

There are no pistons that have a lower compression for our cars, 10.5 is it. My engine is rebuilt also. 

Back to my original response you MAY have other problems. Running lean or passing gear not engaging or hooked up. These are all possible solutions along with the possibility of it being a fuel problem. 

It may be a lean condition causing it to run hot at the plug, have you tried a cooler plug. 

I believe cars for export or maybe California emissions had lower compression engines, my 64 Fleetwood (a California car) has a lower compression engine according to the build sheet.

Today's pumps, at least in the USA, use an average of the old 2 octane rating methods ((Ron + Mon)/2). Using the owners manuals and what they recommended back then it works out to about 94.5 octane with today's pump values. I have never had any issues running 93 or better Octane in my 64 CDV.. before or after rebuild, and with stock carb or the Edelbrock 1411 I currently run.  However, 94.5 would be a minimum and have observed more power when I have added booster or ran higher octane rated gas.

For more details on Octane Ratings check out this Help Page topic:
- Octane Rating Information
 

I guess our tar sands fuel is better than your Texas tea fuels LOL. I do have access to 94 but dont find much if any difference running the 91. The 94 is only at one or two companies and all they do to increase the octane rating is add more ethanol. The distance and effort it takes to get to it isnt worth it. I dont have a carburetor I'm fuel injection. 

I'm running 93 octane in my 63 Coupe DeVille without pinging. I did have a pinging issue in another car (79 Trans Am with 400 SBC). That turned out to be too hot spark plugs. Cooler plugs solved that one.

The cars built for oversea's had the lower compression pistons put into the engines.

Russ, have you seen the pistons available? I have found none doing various online searches. 

I have not, but I have not been looking for them.  I did see an NOS set one time.

RSS

Photos

  • Add Photos
  • View All

Forum

Chrome on door panels.

Started by paul k in 1963/64 Cadillac Specific Discussion. Last reply by Kevin Campbell 3 hours ago. 1 Reply

I want to restore chrome pieces that are attached  to interior door panels.The problem I have is to remove red light lenses .I think it is impossible because the are riveted if I will send to…Continue

clock problem

Started by paul k in General Discussion. Last reply by Russ Austin 7 hours ago. 9 Replies

I would like to ask how to disconnect front clock knob ?Thank youPaulContinue

1963 caddy 2 door hardtop for sale

Started by paul in For Sale. Last reply by paul 8 hours ago. 5 Replies

Just car body and frame. No engine or trans, have front and back seats

Dark cadillac blue engine code anybody

Started by Haris dizdarevic in General Discussion. Last reply by Christopher Codd 15 hours ago. 5 Replies

After a long thought of what color I should paint my cadillac I've finally decided I'd like to paint it the same color as the bill hirsch cadillac dark blue like the engine paint I'm wondering what…Continue

Blog Posts

64 Recirc/Fresh Air Door Actuator replaced; FROM THE INSIDE.

Posted by Norman Silverman on February 4, 2019 at 11:21pm 8 Comments

I am happy to report that I have successfully replaced the Fresh Air/Recirc door actuator that is located on the blower box-and have done so without having to remove the blower box. I did it by taking out the glove box and attacking it from the back.  It took several days, LOTS of patience and some band-aids, but it is done. THE most difficult part -BY FAR- is to remove and then replace the screw that sits on the actuator arm, connecting it to the fresh…

Continue

Flashers

Posted by Mike Petrey on January 13, 2019 at 12:25pm 7 Comments

Where do the flashers go in my 64 Deville Convert.  I'm thinking that's why both turn signals stopped working.

Source for Motor mounts and Trans mounts 1964 SDV

Posted by Norman Silverman on January 9, 2019 at 4:23pm 4 Comments

Hi.

Where is the best place to purchase good quality motor mounts/trans mounts for my 1964 SDV? I see that Rock Auto has them for $8 and change, and others for $24 and change. Big difference. Is there a better place to buy them from?

Thanks

Norm

Videos

  • Add Videos
  • View All

© 2019   Created by Jason Edge.   Powered by

Badges  |  Report an Issue  |  Terms of Service