I have some parts left from parting out my 64 coupe deville to help restore my 63...... let me know what you need and I will see what I have.

I have the transmission that was rebuilt like 5000 miles before car was parted out.

A really good trunk lid (slight surface rust), and a hood with some whammys. still have front and rear seats (need redone)complete rolling chassis with rearend.side and quarter windows.passenger door in good shape. Fender skirts.in dash vacuum hoses.

I Don't have engine or any underhood parts......

Hit me up and let me know what you need. I can email pictures it I have it. my cell 317-370-0784

Views: 535

Reply to This

Replies to This Discussion

Where are you located Bill?

Coatesville, Indiana 46121......... My parts are all at my Dads house in Hazelwood Indiana 46118.

Bill I'm looking for a very good, right, side fender molding.

Clovis, look what I found this morning on ebay..... http://www.ebay.com/itm/1963-Cadillac-Right-Front-Fender-Molding-fr...

Clovis, look what I found this morning on ebay..... http://www.ebay.com/itm/1963-Cadillac-Right-Front-Fender-Molding-fr...

Dont think I have one, but will dig in the storage this weekend.

Do you have one of these that holds vacuum ? AC vacuum Tee it's connected to the Neutral safety switch

hmmm don't remember even seeing one of those....... but maybe, I will look. I do have the coffee can that mounts to the inner fender.

It's under the dash behind the drivers ashtray
Thanks Bill but that is a 63 "top" fender molding. Also a 63 "side" fender molding is different from a 64.

You got me excited there for a second. LOL

OH sorry, my mistake......

The Vacuum hoses you have, are they the set that goes from the power servo through the fire wall to the engine compartment ? mine were cut so I have had to use a connector. So I would be interested in a complete set, you know from power servo to components with no brakes or connectors in the line 

RSS

Photos

  • Add Photos
  • View All

Forum

63 Hydra-Matic won't shift out of first

Started by Norm Waters in 1963/64 Cadillac Specific Discussion. Last reply by Tony and Ginny 429 2 hours ago. 3 Replies

Hello everyone. I had a perfectly good shifting Hydra-Matic transmission until I elected to fix the leak at the dip stick tube. I just did a quick seal with gasket maker since my current tube is…Continue

Rear brake lock up when cold

Started by Cliff Johnston in 1963/64 Cadillac Specific Discussion. Last reply by Tony and Ginny 429 2 hours ago. 1 Reply

Hi everyone, ever since getting the car back on the road, the rear brakes grab when they are cold and I’m moving at slow speed.  Once I get along the road and stop they are fine. I see some posts…Continue

Vacuum advance

Started by Thomas Yarri in 1963/64 Cadillac Specific Discussion. Last reply by Thomas Yarri 15 hours ago. 4 Replies

Good afternoon to all my fellow Cadillac owners! I have a question about the vacuum advance on my car. The car is a 64 without a/c and a Rochester carburetor. I noticed that I have vacuum at the port…Continue

Blog Posts

1963 series 62 convertible transmission issue

Posted by Matthew VanDeWater on June 22, 2021 at 3:03pm 1 Comment

Hello I've been restoring a 63 for way to many years. Down to almost done, but have issue with trans linkage, when column in park shift rod 2 inches short. everything original. been trying to find picture of manual rod hooked up from under car to see position of linkage. was wondering if anybody has access for pictures. I wanted to see if my manual linkage is bent  wrong out of the trans if somebody dropped the trans or something. Doesn't make sense why it doesn't work. Thanks for any input…

Continue

New vehicle in the club

Posted by Patrick Westphal on June 17, 2021 at 4:00pm 1 Comment

I was successful in getting a vehicle from the New York contact I talked about at the last club meeting. I am still trying to figure out how to post a picture of the vehicle that is tied with this comment so if you see a random picture of a black convertible in a yard, that's me haha.  …

Continue

Torque converter grab when idling in Drive

Posted by Cliff Johnston on June 14, 2021 at 8:47pm 2 Comments

Hi Everyone, been quite a while since i have been on here.

I have had an issue with the idle on my 64 Coupe Deville ever since i have had it.

With the Idle set high enough that it is smooth, but still a nice idle, the RPM seems only slightly too high for the stall of the Torque Converter. And therefore it tends to sit there and grab and lunge a bit. So until now, i have been putting the car in Neutral at the lights to stop this happening.

I've had the car dyno tuned and…

Continue

Can you help? Driveshaft Question....

Posted by Chris on May 30, 2021 at 8:55am 1 Comment

Hello!

Newbie to the group here - we have already found tons of invaluable information on the board, so thanks! We are restoring a 1963 Series 62 Convertible. We are wondering if anyone knows of a source to buy the propellor yoke flange (that bolts to the pinion flange) for the driveshaft? One of our ears partially broke off. Not sure if we can buy just the yoke flange as an aftermarket part, or if it has to be rebuilt by a welder/fab guy? Maybe a salvage yard for a source? Again, any…

Continue

Videos

  • Add Videos
  • View All

© 2021   Created by Jason Edge.   Powered by

Badges  |  Report an Issue  |  Terms of Service