Dash Trunk lid warning light and am/fm radio tell-tale lights

I installed the mercury switch trunk light and it works perfectly!  

I half-expected the dash trunk warning light to work as well, but of course it doesn’t.   I crawled under the dash and there is no bulb or bulb socket present.  Did all models come with the trunk warning light, or was it an option?

Also, I noticed recently that the am/fm tale-tale light have gone out.  Are those interior to the radio unit, or bulbs I can replace without having to remove the radio?

I would like to thank everyone for all there advice.  Nearly everything is working in the car as it should, and I’ve learned a lot.  
Mike

Views: 71

Reply to This

Replies to This Discussion

The small AM & FM indicator lights are internal to the radio. There is a separate display light that plugs into the top of the radio that comes on with the rest of the dash lights.

The instrument panel trunk warning light is only used with cars with Power Deck Lid option. See below.

Thank, Jason. That’s what I thought (and gleaned from the service manual).

How hard is it to install the tell-tale bulb for the trunk? I looked through the service manual and could not find any info on how it would normally be wired.

If I decided I wanted to install the tell-tale bulb, could I use the exiting mercury switch and wire the tell-tale bulb in parallel with the trunk bulb? Is there usually a socket or any wiring already in place? If so, anyone know the details?

I've got a '63 Series 62.convertible.

From the factory the feed wire runs from the trunk release actuator assembly mounted on the back wall down the left side of the car under the door sill(s) and behind the dash. It's a pretty simple setup... green wire on ground wire from the mechanism tro the bulb, which has a 12 volt feed from fuse box. When trunk is opened circuit is closed (taken to ground). so you could use this harness (I sell for $45) or make up your own, and have switch that goes to ground when trunk is opened. 

The only problem with the trunk mercury switch is it basically completes it circult and goes to ground at the bulb mercury switch. If you tied a dash light to that 12 volt feed wire to the trunk light it would always be one. The are relays and many ways to skin this cat ... would have to think about this some more. Perhaps others have tried done this.. 

RSS

Photos

  • Add Photos
  • View All

Forum

Rear main seal. 63

Started by Kim K Kaiser in 1963/64 Cadillac Specific Discussion. Last reply by Tony and Ginny 429 16 hours ago. 3 Replies

My rms is leaking again.  I hv cked all other options for leaks and its none of those.  Ie, oil presdure, valve covers, etc.  So i called egge to order another one.  I asked the guy wat contack…Continue

Selling 1964 Coupe Deville Parts

Started by Gary Smiley in For Sale. Last reply by Gary Smiley 17 hours ago. 2 Replies

What I  have are many extra original, hard-to-find 1964 Cadillac Coupe Deville Parts (from donor car).…Continue

Tags: doors, hood, engine

Classic Cadillac Parts For Sale - Misc Items

Started by Jason Edge in For Sale. Last reply by Jason Edge yesterday. 275 Replies

I have posted a few Misc items over on my Classic Cadillac Parts Facebook page at…Continue

Tags: classic cadillac parts, classiccadillacparts

Blog Posts

Rumble Sound at 55-60 mph

Posted by Ray Schick on September 20, 2021 at 10:45pm 6 Comments

64 Coupe DeVille , while driving at 55-60 mph I have a oscillating rumble sound . Steering wheel does not shake or vibrate . Transmission mount looks good .Tires were replaced 2 years ago balanced and rebalanced recently. Axel bearings were just replaced, rear differential assembly was just replaced with a Posi track ,pinion bearings good. Fresh gear lube. Driveshaft checked and balanced the other day ,new center bearing installed and new bearing carrier assembly too. Trying to figure this…

Continue

1963 series 62 convertible transmission issue

Posted by Matthew VanDeWater on June 22, 2021 at 3:03pm 1 Comment

Hello I've been restoring a 63 for way to many years. Down to almost done, but have issue with trans linkage, when column in park shift rod 2 inches short. everything original. been trying to find picture of manual rod hooked up from under car to see position of linkage. was wondering if anybody has access for pictures. I wanted to see if my manual linkage is bent  wrong out of the trans if somebody dropped the trans or something. Doesn't make sense why it doesn't work. Thanks for any input…

Continue

New vehicle in the club

Posted by Patrick Westphal on June 17, 2021 at 4:00pm 1 Comment

I was successful in getting a vehicle from the New York contact I talked about at the last club meeting. I am still trying to figure out how to post a picture of the vehicle that is tied with this comment so if you see a random picture of a black convertible in a yard, that's me haha.  …

Continue

Torque converter grab when idling in Drive

Posted by Cliff Johnston on June 14, 2021 at 8:47pm 2 Comments

Hi Everyone, been quite a while since i have been on here.

I have had an issue with the idle on my 64 Coupe Deville ever since i have had it.

With the Idle set high enough that it is smooth, but still a nice idle, the RPM seems only slightly too high for the stall of the Torque Converter. And therefore it tends to sit there and grab and lunge a bit. So until now, i have been putting the car in Neutral at the lights to stop this happening.

I've had the car dyno tuned and…

Continue

Videos

  • Add Videos
  • View All

© 2021   Created by Jason Edge.   Powered by

Badges  |  Report an Issue  |  Terms of Service