Hey guys.

Im going to be pulling my engine and tranny out soon. Theres some leaks on my engine and tranny. The main reason for this is because i need to paint the engine and engine bay. So i might as well go through everything and replace all gaskets and seals. Im going to be pulling most of the parts off the engine to sandblast and paint. Im pretty new here and was wondering if anyone has a parts list of what i would need. I would want to change front and rear mains seals, valve cover, oil pan seals, etc. If some can help me out with what i will need and maybe what site you guys order off of. That would be appreciated. 

Btw i have 1963 deville series 62. Not sure what transmission it has in it. I have posted pictures of the gear selector since i read on here you can identify tranny from that. I have also posted pictures of the engine so you guys know what im dealing with. LOL. 

Thanks alot guys!

Views: 700

Attachments:

Reply to This

Replies to This Discussion

Do put a new water pump on the engine when its out ( or if doing the timing chain )
The water pump is a job you might like to aviod in the near future

If you do pull the heads to inspect cylinder wear the thing to do is freshen up the heads by seeing what they require
You can see how this becomes opening a can of worms -as they say
If you choose to invest the time and dollars--i second Russ's suggestion that a fresh engine is the best making the car more reliable to take anyplace which is a GOOD thing

If necessary the rebuild can be done in stages with lifes other priorities getting in the way !!

Enjoy

Enjoy

Which water pumps do you guys use. I heard lots of problems with certain ones with incorrect tolerances?

The Cardone wP from Rock Auto is a good one-- thanks to Russ and Clovis who are keeping us out of trouble with bad stuff that comes out of the box new

Enjoy

Hi Klutch,

You could put a vacuum gauge on the car while she is running to get a good overall reading on where you stand before you start pulling things apart that really do not need addressed. You said earlier in your post that the car was running well, had minimal or no blow-by, etc.  

Drive it and enjoy it.  I know there is great temptation to "fix" things while the engine is out and if you have the time and money to do so, it certainly is the opportune time but if your main problem is an engine with lower compression than factory specs, it took 55 years to get to that point so it would seem she is on a very slow decline. 

These are great cars that were built to top notch standards. Sure, they can be improved with some modern technology but why do so if you really do not have to?  Just a penny for your thoughts. 

Happy Cadillacin'!

Well the engine is finally out. I got a couple questions for you guys.

The timing chain was extremely worn, so i will be replacing that. But i pulled the rockers off and just quickly was checking the lifters, i pushed the push rods down into the lifters to do a quick check for worn springs. Some of the lifters were able to be pushed in easily, and some were hard. I did notice a tick before i pulled off the engine also, but it could've been either lifters or leaking exh gaskets. In the manual is states that each lifter must go back into original bore, if i need to replace them do i also need to replace the camshaft too? How about the pushrods, should i keep them all paired together also? Which lifters are good ones for our vehicles?

After i pull the lifters then ill plasti guage the main and rod bearings. 

I broke 3 bolts, 1 on exh manifold, 1 on valve cover, and 1 on front cover. Where can i get new bolts?

Thanks!

I would suggest replacing all lifters and push rods. I bought Melling Brand for my 64 CDV which has what I believe is a dead lifter causing a consistent lifter tick/tap. I have not gotten around to it but will soon. I could have tried to isolate the bad lifter or lifters but it is good insurance to go ahead and replace them and dead lifters can warp or bend push rods doe to the slack.  See pictures below of lifters and receipt with the part #'s. 

Bolts:
Exhaust: I have either length bolt in VG condition and sell the longer 2 1/4” bolts in VG+ condition for $3 each, I sell the two shorter (and harder to find) 1 1/2” bolts for $7.50 each

Valve Cover: the valve cover bolt and washer ($1 each)

Front Engine Cover: There are 17 bolts spanning 7 sizes. I would have all. Most are $2 each.

Email me at jasonedge@nc.rr.com if interested in the bolts. I will need specs on the front engine cover bolt, or I can reply with illustration with bolt sizes and lengths.

Hey jason i have a 63 btw. I cant find the melling lifters on rockauto

Push Rods were the same 63 to 66. Valve Lifters were the same 58 to 66. I see a few other brands on Rock Auto. I like the Melling as they are known for being a quality USA Made produce.  I seen the JB-969 on Amazon for 4.95 with free shipping.

Can i change just lifters and pushrods without changing the camshaft?

Yes. I am however, my camshaft should be about new with less than 4K miles on it. Since engine is out and you said timing chain is very worn, camshaft lobes probably  have a good amount of wear and would be a good time to replace it. I think once lifters are out you can look in to the lifter bores with a good light and rotate the engine and observe the wear on the lifter lobes. Again, since engine is partly apart and assume you are replacing all lifters and pushrods anyway, it would be a good time to replace the camshaft. You can get new ones from Kanter, USA Parts, maybe Rock Auto, etc. There is a mild HP gain cam available that I installed when I rebuilt mine. You can read specs and see discussion on it here on a different thread by Clicking Here.

Jason 

There is an outside chance you may have a bent push rod making your ticking noise as one  of the options causing the valve noise 

Correct me if  you have a different understanding but from what I know the current replacement push rods are not as good  quality as the old stock ones and can bend more easily 

Checking for a push rod issue is an easy first step and possible fix for that ticking sound 

I would imagine you changed out all your lifters when the engine was redone with the new cam being installed at that time 

Why would a new lifter fail in such a short time as that seems a little odd to me and very short lived 

Just thinking you might get luck as that would be a quick fix if it applies 

Feels like a good first place to start to attack the issue when you get to it 

Enjoy 

RSS

Photos

  • Add Photos
  • View All

Forum

Is this possible or total BS?

Started by Kim K Kaiser in 1963/64 Cadillac Specific Discussion. Last reply by Tony and Ginny 429 4 hours ago. 5 Replies

After changing tie rods, i tokk car into wheel n allignment shop. He said no problem.  He calls back about 45 minutes later and said they couldnt get between the tire and cowl, the guys head was too…Continue

Vacuum / Parking Brake / NSS Question

Started by Karl Schwarz in 1963/64 Cadillac Specific Discussion. Last reply by Karl Schwarz 6 hours ago. 2 Replies

I bought a 1963 Series 62 Convertible in July.It makes a hissing sound when in neutral, and sometimes when in drive (when the shift is more to the left that the right. I assume this related to a NSS…Continue

Tail pipe black stuff!

Started by Lambert Ross in 1963/64 Cadillac Specific Discussion. Last reply by Lambert Ross yesterday. 10 Replies

any ideas how to clear the ugly black stuff shooting out from my tailpipe? After a long layover, it really messes up the garage floor. I assume its carbon but am not sure how best to react to it.…Continue

Blog Posts

still need a driveshaft

Posted by wayne weaver on November 26, 2019 at 11:53am 0 Comments

well thank you UPS for losing the driveshaft that Russ Austin shipped me. 

however i still need a rear driveshaft section for my 63. mine has a vibration due to the bushing inside of it. its a shame because the ball and sockets in the cardian joints are perfect but it has a woble on the balancing machine. so .  still need the rear section. anyone have a good one ? is there driveshaft alternatives to use ? i am really considering an LS swap and since im fighting the driveshaft search…

Continue

63 guidematic issues

Posted by maurice lapoiinte on November 24, 2019 at 3:10pm 0 Comments

 So my 63 guide matic headlamps stay on low beam all the time. I have so far bypassed the system and everything works normal. I have been thru the trouble shooting in the manual but this is where the confusion begins.on my car when the power relay is powered I have low beam and when its not powered I have highbeam, this appears to be opposite what the diagnosis says should be correct.The wiring is all original and no wires have been mixed up.has anyone ever unplugged the 2 wire connector…

Continue

Another advantage of the Pertronix III

Posted by Doug Scarrow on November 23, 2019 at 11:12am 1 Comment

   Having tried both the II and III I can say the multispark feature of the III offers a smoother idle . It is also easier to install .Does not require removal of the distributor

Stuck at two red (dash) lights!

Posted by Jeff Kinzler on November 3, 2019 at 10:00pm 9 Comments

I hope someone can help solve these two electrical problems that appeared one after the other.

By way of background: The car, a '64 Eldorado has very limited use. It was at a restoration shop for 15 months until last January-  that supposedly did a bunch of wiring repairs including rebuilding the gas gauge that still hasn't worked properly, and the clock that hasn't worked, and re-soldering the broken wires in the drive door. All window and seat controls appear to be…

Continue

Videos

  • Add Videos
  • View All

© 2019   Created by Jason Edge.   Powered by

Badges  |  Report an Issue  |  Terms of Service