Regards from Finland!

I have owned 1964 sedan 62s from september 2020. I´ve repaired carb, oilpump, gaspump, replaced new coil and waterpump, new oil pan and trans oilpan gasgets and electric choke, new timing chain etc.

I parked the car in garage almost 8 months ago and took testdrive today.

Engine is great and carb works nice.

Somehow windows and power seat was not working. I used windows few monts ago when car was pushed outside to -10 celsius degrees for one day. Window fuse is ok and test pen showed connection is ok. Any tips? Seat and window have same fuse, right? What about relay?

T

Views: 57

Reply to This

Replies to This Discussion

Check for broken wires in the door jamb. This is a common problem since the wires flex every time the door is opened. After 57 years they can break. It is easy to remove the rubber boot and check.

Thank you for help and excellent pictures!

I checked the wires and looked like someone has repaired them previously. While cheking wires and fuse box I noticed that there was 2 loosen wires hanging above the box. I guess at least other one has loosen when I took power to electric choke. I connected them on the right side of fusebox connectors and windows and seat was ok!

The other, very short, wire was deep among harnesses and I noticed it like by chance. This was for windows.

T

The photos do  explain that as clearly  as is possible 

Great post and a very needed and necessary repair that needs doing in most of our cars at some point in time 

Enjoy 

RSS

Photos

  • Add Photos
  • View All

Forum

Rear main seal. 63

Started by Kim K Kaiser in 1963/64 Cadillac Specific Discussion. Last reply by Tony and Ginny 429 15 hours ago. 3 Replies

My rms is leaking again.  I hv cked all other options for leaks and its none of those.  Ie, oil presdure, valve covers, etc.  So i called egge to order another one.  I asked the guy wat contack…Continue

Selling 1964 Coupe Deville Parts

Started by Gary Smiley in For Sale. Last reply by Gary Smiley 16 hours ago. 2 Replies

What I  have are many extra original, hard-to-find 1964 Cadillac Coupe Deville Parts (from donor car).…Continue

Tags: doors, hood, engine

Classic Cadillac Parts For Sale - Misc Items

Started by Jason Edge in For Sale. Last reply by Jason Edge 22 hours ago. 275 Replies

I have posted a few Misc items over on my Classic Cadillac Parts Facebook page at…Continue

Tags: classic cadillac parts, classiccadillacparts

Blog Posts

Rumble Sound at 55-60 mph

Posted by Ray Schick on September 20, 2021 at 10:45pm 6 Comments

64 Coupe DeVille , while driving at 55-60 mph I have a oscillating rumble sound . Steering wheel does not shake or vibrate . Transmission mount looks good .Tires were replaced 2 years ago balanced and rebalanced recently. Axel bearings were just replaced, rear differential assembly was just replaced with a Posi track ,pinion bearings good. Fresh gear lube. Driveshaft checked and balanced the other day ,new center bearing installed and new bearing carrier assembly too. Trying to figure this…

Continue

1963 series 62 convertible transmission issue

Posted by Matthew VanDeWater on June 22, 2021 at 3:03pm 1 Comment

Hello I've been restoring a 63 for way to many years. Down to almost done, but have issue with trans linkage, when column in park shift rod 2 inches short. everything original. been trying to find picture of manual rod hooked up from under car to see position of linkage. was wondering if anybody has access for pictures. I wanted to see if my manual linkage is bent  wrong out of the trans if somebody dropped the trans or something. Doesn't make sense why it doesn't work. Thanks for any input…

Continue

New vehicle in the club

Posted by Patrick Westphal on June 17, 2021 at 4:00pm 1 Comment

I was successful in getting a vehicle from the New York contact I talked about at the last club meeting. I am still trying to figure out how to post a picture of the vehicle that is tied with this comment so if you see a random picture of a black convertible in a yard, that's me haha.  …

Continue

Torque converter grab when idling in Drive

Posted by Cliff Johnston on June 14, 2021 at 8:47pm 2 Comments

Hi Everyone, been quite a while since i have been on here.

I have had an issue with the idle on my 64 Coupe Deville ever since i have had it.

With the Idle set high enough that it is smooth, but still a nice idle, the RPM seems only slightly too high for the stall of the Torque Converter. And therefore it tends to sit there and grab and lunge a bit. So until now, i have been putting the car in Neutral at the lights to stop this happening.

I've had the car dyno tuned and…

Continue

Videos

  • Add Videos
  • View All

© 2021   Created by Jason Edge.   Powered by

Badges  |  Report an Issue  |  Terms of Service