Hey everyone,  how sensitive should the power brakes be?  I have just rebuilt the power booster and  replaced the master cylinder. The pedal doesn’t have any resistance so I have to be very gentle so they don’t throw me through the windshield.   I’ve tried using them without the booster and they aren’t as aggressive so I’m thinking it’s not the shoes, I’ve adjusted and readjusted the booster’s pushrod with a gauge to no avail.   Is it possible for the brake booster spring to wear out?   I’ve replaced shoes, wheel cylinders, flexible brake lines, turned drums, master cylinder, and rebuilt booster.   Any advice would be appreciated, 

Views: 222

Reply to This

Replies to This Discussion

 Phil

The brakes should not be stopping you as aggressively as you are describing 

The brake peddle  should have about a 1/2 inch  of travel and then a very hard peddle unlike ABS brakes used today when correct in these years 

It might be the brake shoes are binding when making contact with the drum 

Brake shoes can become Glazed  ( damaged ) from to much heat when the shoe material is not up to par 

If that is the case the shoes will look shinny and possibly have some damage (  cracking ) when visually inspected which you should do 

I have been doing my own brakes for about 50 years ( all my own cars ) and this is still  only my best guess based on your description

If the brake shoes are in question I would recommend using Raybestos brake shoes which are the only brand that I have ever used in all my cars

I had my brakes done— once by a shop when I had my  64 convert gone over from bumper to bumper at a shop and the shoes they used were a complete disaster as they chattered so much it felt like the front of my Cadillac was going to fall off  ( no kiding )  and that is the way they gave me the car back ( nuts ) after spending thousands 

It took me a while to determine that the— New brake shoes —were the issue as they were not suspect at first because —they were a brand new parts  installed 

I would strongly suggest that you do —replace all the brake springs as they subject to a lot of heat and cooling which can fatigue the metal and might be part of your issue 

I got mine at Kanter in NJ 

They have two kinds—  for self adjusting brakes and for those who have removed the  stock self adjusters 

I would recommend you keep the self adjusters and clean them up as they are convenient to be using as unlike other cars our Cadillac brakes are adjusted - from the front of the brake drum which is a pain 
When an individual brake is adjusted correctly with the tire on the drum you should be able to grab the tire and it should spin one full turn and stop where you started the spin— indicating the drag is correct 

The brakes might be adjusted to tight and will cause excessive heat to build up in them after a short  test drive 

Enjoy 

The conditions you are describing (no pedal resistance, harsh stopping) would lead me to think the shoes are adjusted in much too far.  You could also have broken hardware.

Broken spring in the booster would apply the brakes all the time, the springs in the booster are only there to release, not for feel.  

Thanks for the replies,  I ordered new hardware, that’s the only thing I haven’t replaced, and I’ll check the adjustment.    Before I did the booster and master cylinder they worked ok but not great, now it’s the complete opposite.  

Brake fluid on the shoes will cause the brakes to grab. 

Sometimes the push rod height is incorrectly set and the compensating port being blocked.

But Russ answer is most likely the main reason for your problem.

A little bit of an update,  I replaced the front shoes with the rabestos organic shoes and they are working much better,  I think they may have been overheated.  Now All i have is the pedal travel is a little bit too much,  I’m going to readjust the shoes and check if I left some air in the lines when I bled them.    I’ve never had so much trouble with brakes..  

Ok second  update, the shoe replacement didn’t really work so Per Andre’s advice I revisited the pushrod adjustment. The manual doesn’t give any specification on what the size of the gauge should be, so I used a universal brake booster depth gauge that I got from a corvette parts supplier.  The gauge measures the depth of the master cylinder so you can set the pushrod to be just a kiss away from the Back of the plunger..   Here is where I’m confused, the shorter the pushrod the more violent the braking,   I just adjusted the pushrod in 1/4” increments and now the brakes feel normal, no more whiplash,  is this the right way to go about this? 
So now the problem I have is the the brakes vibrate, stick, chatter. I’ve read a few people on  this site praising the rabestos shoes, those posts are from a few years back, could they have lost their quality control?  The shoes I purchased were the element 3 organic.   I’m 99% sure they were adjusted properly.  
I feel like I’m almost there, I’ve never had so much trouble with brake before 
thanks. 

is there a chance that one of the sets of shoes is on backwards?

i've seen primary and secondary shoes reversed too many times, or both primary on one wheel with the secondaries on the other.

if the shoes are reversed, they will do exactly that, stick, chatter, vibrate, lock up.   Not saying that it happened, but it's possible.

Hey Mark 

All the brake shoes are all the same size on all four hubs on these Cadillacs ( no small and bigger ) 

But a very good observation  regarding many other cars 

Enjoy 

Thanks Mark,  I wish that was the issue,  I’ve checked that a few times. 

Have you changed or rebuilt your brake cylinders and replaced the rubber brake lines which is all part of a brake refresh ?

I think you may have overheated your new brake shoes due to your brake booster rod not being adjusted correctly until your last adjustments 

Overheating the shoes causes the chatter and binding you are now making note of 

At anytime did you feel the brakes dragging on the last outing test drive ?

What does element 3 organic brake shoes mean??

Never heard that term before 

Enjoy

Thanks Tony.   Element 3 organic is what Raybestos is branding their shoes and pads as.  I’ve read past posts of you and a few others recommending raybestos, I’ve used them on other cars I’ve owned without a problem, so I figured I couldn’t go wrong.  Those posts are from a few years ago, and they’ve changed ownership since, that got me thinking there might be a QC issue.   As far as test driving I wasn’t driving the car aggressively and i could make the car come to a gentle stop by ever so gently applying the pedal.  I definitely burned out the original set,  and I thought I was careful enough not to burn up the second.  Either way I ordered a third set of shoes to try out, this time they’re the riveted Dynamic Friction brand,  we’ll see how that goes.  

RSS

Photos

  • Add Photos
  • View All

Forum

Whoa there, you want how much??

Started by Robert Gonzalez in 1963/64 Cadillac Specific Discussion. Last reply by Robert Gonzalez 11 hours ago. 3 Replies

Ok, I’ve been on here for almost a decade. I KNOW we covet our cars and have always tried selling them at premium prices. But the bottom line, our cars rarely fetched prices over a covair. The…Continue

Free- 64 lower bumper bucket - Passenger side

Started by Michael Buonaccorso in For Sale. Last reply by Michael Buonaccorso 23 hours ago. 2 Replies

This is in rough shape. Not only is there rust in the usual places but it is also bent. I replaced this piece on my car after an accident, but since this is a hard to come by piece, I figured someone…Continue

1964 Cadillac parts for sale... northern cali

Started by Jason in For Sale. Last reply by Jeremy on Friday. 1 Reply

Bill Hirsch cast iron gray exhaust and manifold paint (1 can) $20Bill hirsch Cadillac dark blue engine enamel high temp high gloss (2 cans) $40Convertible top latchValve coversHeadlight bezelRadioGas…Continue

Tags: Parts

63 4 door Cadillac

Started by Walt Timmerman in For Sale. Last reply by Jeremy on Friday. 7 Replies

Need to start parting this car out. Might be moving soon and if its not parted out, it'll be scrapped.Also have Motor and transmission from my 63 coupe deville for sale. will part out also.Was told…Continue

Blog Posts

Rumble Sound at 55-60 mph

Posted by Ray Schick on September 20, 2021 at 10:45pm 6 Comments

64 Coupe DeVille , while driving at 55-60 mph I have a oscillating rumble sound . Steering wheel does not shake or vibrate . Transmission mount looks good .Tires were replaced 2 years ago balanced and rebalanced recently. Axel bearings were just replaced, rear differential assembly was just replaced with a Posi track ,pinion bearings good. Fresh gear lube. Driveshaft checked and balanced the other day ,new center bearing installed and new bearing carrier assembly too. Trying to figure this…

Continue

1963 series 62 convertible transmission issue

Posted by Matthew VanDeWater on June 22, 2021 at 3:03pm 1 Comment

Hello I've been restoring a 63 for way to many years. Down to almost done, but have issue with trans linkage, when column in park shift rod 2 inches short. everything original. been trying to find picture of manual rod hooked up from under car to see position of linkage. was wondering if anybody has access for pictures. I wanted to see if my manual linkage is bent  wrong out of the trans if somebody dropped the trans or something. Doesn't make sense why it doesn't work. Thanks for any input…

Continue

New vehicle in the club

Posted by Patrick Westphal on June 17, 2021 at 4:00pm 1 Comment

I was successful in getting a vehicle from the New York contact I talked about at the last club meeting. I am still trying to figure out how to post a picture of the vehicle that is tied with this comment so if you see a random picture of a black convertible in a yard, that's me haha.  …

Continue

Torque converter grab when idling in Drive

Posted by Cliff Johnston on June 14, 2021 at 8:47pm 2 Comments

Hi Everyone, been quite a while since i have been on here.

I have had an issue with the idle on my 64 Coupe Deville ever since i have had it.

With the Idle set high enough that it is smooth, but still a nice idle, the RPM seems only slightly too high for the stall of the Torque Converter. And therefore it tends to sit there and grab and lunge a bit. So until now, i have been putting the car in Neutral at the lights to stop this happening.

I've had the car dyno tuned and…

Continue

Videos

  • Add Videos
  • View All

© 2021   Created by Jason Edge.   Powered by

Badges  |  Report an Issue  |  Terms of Service