Hello,

my name is Stefan and this is my first post in this forum. I´m from germany and very happy to own and drive a 1963 Fleetwood 60 Special in a very nice condition. It has been delivered by Cadillac Switzerland in 1963 to a 5* hotel in Portugal and was used as a VIP shuttle for guests.

A lot of technical issues have already been resolved , but there are still some ToDo´s on my list. I am very happy to have found this forum and looking forward to lots of good conversations and infos.

So my actual ToDo is an ignition upgrade to a Pertronix ignition.

Engine is the original 390cui with the stock Carter carburetor and ca. 52.000mls of total mileage.

My question is:

Do you have any recommendations for a Pertronix ingition? I, II or III ? with/without Lobe Sensor? 

Will the Pertronix I be completely sufficent, or do you recommend e.g. the II?

Thank you in advance for your help!

Views: 66

Reply to This

Replies to This Discussion

Grats on a 63 purchase, you wont be disappointed.  I recommend #3 as it offers the best protection and ease of installation. 

Running the points is also just fine.  I have the #2 on a 63 sedan and points on a 63 series 60.  Both run just fine.  

  The II or III is what I recommend The I has the weakness of failing if you leave the key on without it running. The II and III do not have this problem ,they also have adaptive dwell and sense cranking speed and retard the timing slightly only when cranking over to aid hot starting. The III has multispark which can make for a smoother idle.

I'm running the II and added the Flamethrower coil as well and have been very happy with it. There are details on each and installation tips under the Help tab In the header above.

Pertronix Ignitor Ignition & Flamethrower I, II, and III Compar... 

Pertronix II & Flamethrower II Installation by Anders

RSS

Photos

  • Add Photos
  • View All

Forum

63 Hydra-Matic won't shift out of first

Started by Norm Waters in 1963/64 Cadillac Specific Discussion. Last reply by Tony and Ginny 429 2 hours ago. 3 Replies

Hello everyone. I had a perfectly good shifting Hydra-Matic transmission until I elected to fix the leak at the dip stick tube. I just did a quick seal with gasket maker since my current tube is…Continue

Rear brake lock up when cold

Started by Cliff Johnston in 1963/64 Cadillac Specific Discussion. Last reply by Tony and Ginny 429 2 hours ago. 1 Reply

Hi everyone, ever since getting the car back on the road, the rear brakes grab when they are cold and I’m moving at slow speed.  Once I get along the road and stop they are fine. I see some posts…Continue

Vacuum advance

Started by Thomas Yarri in 1963/64 Cadillac Specific Discussion. Last reply by Thomas Yarri 15 hours ago. 4 Replies

Good afternoon to all my fellow Cadillac owners! I have a question about the vacuum advance on my car. The car is a 64 without a/c and a Rochester carburetor. I noticed that I have vacuum at the port…Continue

Blog Posts

1963 series 62 convertible transmission issue

Posted by Matthew VanDeWater on June 22, 2021 at 3:03pm 1 Comment

Hello I've been restoring a 63 for way to many years. Down to almost done, but have issue with trans linkage, when column in park shift rod 2 inches short. everything original. been trying to find picture of manual rod hooked up from under car to see position of linkage. was wondering if anybody has access for pictures. I wanted to see if my manual linkage is bent  wrong out of the trans if somebody dropped the trans or something. Doesn't make sense why it doesn't work. Thanks for any input…

Continue

New vehicle in the club

Posted by Patrick Westphal on June 17, 2021 at 4:00pm 1 Comment

I was successful in getting a vehicle from the New York contact I talked about at the last club meeting. I am still trying to figure out how to post a picture of the vehicle that is tied with this comment so if you see a random picture of a black convertible in a yard, that's me haha.  …

Continue

Torque converter grab when idling in Drive

Posted by Cliff Johnston on June 14, 2021 at 8:47pm 2 Comments

Hi Everyone, been quite a while since i have been on here.

I have had an issue with the idle on my 64 Coupe Deville ever since i have had it.

With the Idle set high enough that it is smooth, but still a nice idle, the RPM seems only slightly too high for the stall of the Torque Converter. And therefore it tends to sit there and grab and lunge a bit. So until now, i have been putting the car in Neutral at the lights to stop this happening.

I've had the car dyno tuned and…

Continue

Can you help? Driveshaft Question....

Posted by Chris on May 30, 2021 at 8:55am 1 Comment

Hello!

Newbie to the group here - we have already found tons of invaluable information on the board, so thanks! We are restoring a 1963 Series 62 Convertible. We are wondering if anyone knows of a source to buy the propellor yoke flange (that bolts to the pinion flange) for the driveshaft? One of our ears partially broke off. Not sure if we can buy just the yoke flange as an aftermarket part, or if it has to be rebuilt by a welder/fab guy? Maybe a salvage yard for a source? Again, any…

Continue

Videos

  • Add Videos
  • View All

© 2021   Created by Jason Edge.   Powered by

Badges  |  Report an Issue  |  Terms of Service