Good afternoon to all my fellow Cadillac owners! I have a question about the vacuum advance on my car. The car is a 64 without a/c and a Rochester carburetor. I noticed that I have vacuum at the port when cold idling but not when hot and idling. Is this normal? The car seems to run fine, but I thought I should have constant vacuum.

Views: 65

Reply to This

Replies to This Discussion

When you say cold idling is the choke engaged and pushing up the rpm? If so then you would have some vaccum with the throttle is parially opened from the choke. .. at least that is what i remember when I had the stock carb setup with choke.

When I first start the car before the choke fully opens there is vacuum, but after the choke opens I have no vacuum at idle. The car drives great but it seemed strange to me.

rpm?  off choke it should be idling at about 480 rpm, and since these are ported no vacuum. On Choke on I believe is 1700 rpm. With AC on and Idle speed up engaged about 900 rpm.  As the accelerator is engaged the ported vacuum system will introduce vacuum. It has been a very long time since I have had a stock carb. Perhaps someone with a stock carb can provide some vacuum spec at 480 rpm idle, 900 rpm AC on, Choke off, 1700 rpm Choke full on.

Thank you as always Jason, I figured it should have been normal, I recently found out the car had a modified Chevrolet carburetor on it and I switched to the proper Rochester. I am idling at around 480 engine warm. The car is running so much better than it did. 

RSS

Photos

  • Add Photos
  • View All

Forum

Classic Cadillac Parts For Sale - Misc Items

Started by Jason Edge in For Sale. Last reply by Jason Edge 1 hour ago. 287 Replies

I have posted a few Misc items over on my Classic Cadillac Parts Facebook page at…Continue

Tags: classic cadillac parts, classiccadillacparts

64 caddie Brake drums

Started by mark zimmerman in 1963/64 Cadillac Specific Discussion. Last reply by Tony and Ginny 429 2 hours ago. 2 Replies

Are the front  brake drums the same as the rear ones? I had my garage install new drums on the car and now at 25-35 mph the car shakes like the  front wheels are going to fall off. Car has new brakes…Continue

Caddy Cruising with the Family

Started by Jason Edge in General Discussion 15 hours ago. 0 Replies

I've had a great couple of weeks entertaining family since Oct 11, and the 64 Caddy has played a big part.  Knowing aunts and uncles and many other relatives would be joining us for a celebration of…Continue

64 front passenger fender removal

Started by Chris Mcdougal in 1963/64 Cadillac Specific Discussion. Last reply by Jason Edge 17 hours ago. 1 Reply

Hey guys I have search around the discussion boards and can't find anything.. but trying to get this passenger front fender off of my 64 deville 6 window got all the obvious ones and the one behind…Continue

Tags: removal, Fender

Blog Posts

Rochester throttle body gasket

Posted by Phil on September 29, 2021 at 8:18am 5 Comments

Hello,  would anybody be able to tell me if I’m using the correct gasket on my Rochester throttle body? It doesn’t  look right to me.  I’m not sure if the carb actually ran with this gasket because I got it used with no history.  Any help would be appreciated …

Continue

Rumble Sound at 55-60 mph

Posted by Ray Schick on September 20, 2021 at 10:45pm 6 Comments

64 Coupe DeVille , while driving at 55-60 mph I have a oscillating rumble sound . Steering wheel does not shake or vibrate . Transmission mount looks good .Tires were replaced 2 years ago balanced and rebalanced recently. Axel bearings were just replaced, rear differential assembly was just replaced with a Posi track ,pinion bearings good. Fresh gear lube. Driveshaft checked and balanced the other day ,new center bearing installed and new bearing carrier assembly too. Trying to figure this…

Continue

1963 series 62 convertible transmission issue

Posted by Matthew VanDeWater on June 22, 2021 at 3:03pm 1 Comment

Hello I've been restoring a 63 for way to many years. Down to almost done, but have issue with trans linkage, when column in park shift rod 2 inches short. everything original. been trying to find picture of manual rod hooked up from under car to see position of linkage. was wondering if anybody has access for pictures. I wanted to see if my manual linkage is bent  wrong out of the trans if somebody dropped the trans or something. Doesn't make sense why it doesn't work. Thanks for any input…

Continue

New vehicle in the club

Posted by Patrick Westphal on June 17, 2021 at 4:00pm 1 Comment

I was successful in getting a vehicle from the New York contact I talked about at the last club meeting. I am still trying to figure out how to post a picture of the vehicle that is tied with this comment so if you see a random picture of a black convertible in a yard, that's me haha.  …

Continue

Videos

  • Add Videos
  • View All

© 2021   Created by Jason Edge.   Powered by

Badges  |  Report an Issue  |  Terms of Service