Jan Johansson
  • Male
  • Linkoping
  • Sweden
Share on Facebook
Share
  • Blog Posts
  • Discussions (6)
  • Events
  • Photos
  • Photo Albums
  • Videos
 

Jan Johansson's Page

Latest Activity

Jan Johansson replied to Matti Roth's discussion Unknown parts quiz Episode 4
"Part 1 is a bracket for one of the cooler line clips in photo 3, the bracket is attached to one of the front oil pan studs. The right bracket in photo 2 could be the washer fitted between the starter bracket and the oil pan. I dont think the left…"
Sep 13
Jan Johansson replied to Dan McNarry's discussion Replacement Rear Trailing Arms
"Hello Dan I hope you continue providing trailing arms. I plan to order a pair later this year Jan"
Jul 26
Jan Johansson replied to Daniel Grande's discussion 63 coupedebille fuel pump issues
"The engine mount looks weird, the bracket is mounted on wrong side."
Jun 23
Jan Johansson replied to Kim K Kaiser's discussion What does this wire go to
"The yellow wire should be connected to the starter solenoid and Ignition coil +, its hot 12v during cranking to provide full 12v to coil. The resistor wire provides reduced voltage to the coil during normal driving."
May 23

Profile Information

Do you own any 1963 & 1964 Cadillacs? If Yes, Year & Body Style
1964 60 Special
Cadillac LaSalle Club Member? If Yes, Membership #?
No
1963/64 Cadillac Chapter Member?
No

Comment Wall (1 comment)

You need to be a member of 63/64 Cadillac Website to add comments!

Join 63/64 Cadillac Website

At 6:38pm on January 13, 2018, Jason Edge said…

Welcome to the 63/64 Cadillac Website. 

This site is hosted by the CLC (Cadillac LaSalle Club) 1963/64 Cadillac Chapter. Joining the website is free to everyone, however, you must be a CLC member to join the chapter. 

- Click Here for more information on joining the 1963/64 Cadillac Chapter and the Cadillac LaSalle Club

Be sure and check out all the links and pages and make yourself at home.  The Help Page at www.help.6364cadillac.com will have links to many useful articles and information about our Cadillacs.

 
 
 

Photos

  • Add Photos
  • View All

Forum

Rear main seal. 63

Started by Kim K Kaiser in 1963/64 Cadillac Specific Discussion. Last reply by Tony and Ginny 429 9 hours ago. 3 Replies

My rms is leaking again.  I hv cked all other options for leaks and its none of those.  Ie, oil presdure, valve covers, etc.  So i called egge to order another one.  I asked the guy wat contack…Continue

Selling 1964 Coupe Deville Parts

Started by Gary Smiley in For Sale. Last reply by Gary Smiley 10 hours ago. 2 Replies

What I  have are many extra original, hard-to-find 1964 Cadillac Coupe Deville Parts (from donor car).…Continue

Tags: doors, hood, engine

Classic Cadillac Parts For Sale - Misc Items

Started by Jason Edge in For Sale. Last reply by Jason Edge 17 hours ago. 275 Replies

I have posted a few Misc items over on my Classic Cadillac Parts Facebook page at…Continue

Tags: classic cadillac parts, classiccadillacparts

Blog Posts

Rumble Sound at 55-60 mph

Posted by Ray Schick on September 20, 2021 at 10:45pm 6 Comments

64 Coupe DeVille , while driving at 55-60 mph I have a oscillating rumble sound . Steering wheel does not shake or vibrate . Transmission mount looks good .Tires were replaced 2 years ago balanced and rebalanced recently. Axel bearings were just replaced, rear differential assembly was just replaced with a Posi track ,pinion bearings good. Fresh gear lube. Driveshaft checked and balanced the other day ,new center bearing installed and new bearing carrier assembly too. Trying to figure this…

Continue

1963 series 62 convertible transmission issue

Posted by Matthew VanDeWater on June 22, 2021 at 3:03pm 1 Comment

Hello I've been restoring a 63 for way to many years. Down to almost done, but have issue with trans linkage, when column in park shift rod 2 inches short. everything original. been trying to find picture of manual rod hooked up from under car to see position of linkage. was wondering if anybody has access for pictures. I wanted to see if my manual linkage is bent  wrong out of the trans if somebody dropped the trans or something. Doesn't make sense why it doesn't work. Thanks for any input…

Continue

New vehicle in the club

Posted by Patrick Westphal on June 17, 2021 at 4:00pm 1 Comment

I was successful in getting a vehicle from the New York contact I talked about at the last club meeting. I am still trying to figure out how to post a picture of the vehicle that is tied with this comment so if you see a random picture of a black convertible in a yard, that's me haha.  …

Continue

Torque converter grab when idling in Drive

Posted by Cliff Johnston on June 14, 2021 at 8:47pm 2 Comments

Hi Everyone, been quite a while since i have been on here.

I have had an issue with the idle on my 64 Coupe Deville ever since i have had it.

With the Idle set high enough that it is smooth, but still a nice idle, the RPM seems only slightly too high for the stall of the Torque Converter. And therefore it tends to sit there and grab and lunge a bit. So until now, i have been putting the car in Neutral at the lights to stop this happening.

I've had the car dyno tuned and…

Continue

Videos

  • Add Videos
  • View All

© 2021   Created by Jason Edge.   Powered by

Badges  |  Report an Issue  |  Terms of Service