1964 Cadillac Fleetwood Sixty special will die if I gear it to drive, and it will have a hart time to start up again

Hello guys, I’m to the point of throwing the towel, I took my caddy to a mechanic that apparently he doesn’t know what he is doing, I was told that I need to clean de carburetor which it was done by the mechanic, now he is telling me that the cars stars but when he put car in Drive the car will stall unless he give more gas ,  now he want for me to get a new carburetor, he make me buy new parts, but I’m sure that he want to rip me off, I will like to know what may be causing the car to stall, I’m despertarte And don’t know what to do. Thank you for any help,

Views: 84

Comment

You need to be a member of 63/64 Cadillac Website to add comments!

Join 63/64 Cadillac Website

Comment by Tony and Ginny 429 on May 8, 2020 at 1:02pm

Did the engine ever run with the present carb and electric fuel pump you now are using before your low end engine build was done 

Russ is good with electric pumps in our year cars so tell him which pump you have especially if it was just installed in the car 

Stay Safe 

Comment by Russ Austin on May 8, 2020 at 7:43am

If the mechanic said the carb gets clogged with gas, then that tells me it is flooding out. You either have too much fuel pressure or the floats are set wrong.  What electric fuel pump did you put on?

Comment by Pablo on May 7, 2020 at 11:53pm
thank you very much, I’m very new on these, I got a new block, they put new piston rings and push roads, the car start with an electric pump but The mechanic told me that the carb gets clogged with gas, at this point I going to take the car to my house and start working on my own, Thank you so much
Comment by Tony and Ginny 429 on May 7, 2020 at 11:27pm

Sounds like the points and timing are out of adjustment
When was the engine tuned up last time ? 
What was the car doing for you to bring it to a shop for repair ?

Enjoy 

Photos

  • Add Photos
  • View All

Forum

63 Hydra-Matic won't shift out of first

Started by Norm Waters in 1963/64 Cadillac Specific Discussion. Last reply by Norm Waters 2 hours ago. 7 Replies

Hello everyone. I had a perfectly good shifting Hydra-Matic transmission until I elected to fix the leak at the dip stick tube. I just did a quick seal with gasket maker since my current tube is…Continue

Rear brake lock up when cold

Started by Cliff Johnston in 1963/64 Cadillac Specific Discussion. Last reply by Tony and Ginny 429 19 hours ago. 1 Reply

Hi everyone, ever since getting the car back on the road, the rear brakes grab when they are cold and I’m moving at slow speed.  Once I get along the road and stop they are fine. I see some posts…Continue

Vacuum advance

Started by Thomas Yarri in 1963/64 Cadillac Specific Discussion. Last reply by Thomas Yarri yesterday. 4 Replies

Good afternoon to all my fellow Cadillac owners! I have a question about the vacuum advance on my car. The car is a 64 without a/c and a Rochester carburetor. I noticed that I have vacuum at the port…Continue

Blog Posts

1963 series 62 convertible transmission issue

Posted by Matthew VanDeWater on June 22, 2021 at 3:03pm 1 Comment

Hello I've been restoring a 63 for way to many years. Down to almost done, but have issue with trans linkage, when column in park shift rod 2 inches short. everything original. been trying to find picture of manual rod hooked up from under car to see position of linkage. was wondering if anybody has access for pictures. I wanted to see if my manual linkage is bent  wrong out of the trans if somebody dropped the trans or something. Doesn't make sense why it doesn't work. Thanks for any input…

Continue

New vehicle in the club

Posted by Patrick Westphal on June 17, 2021 at 4:00pm 1 Comment

I was successful in getting a vehicle from the New York contact I talked about at the last club meeting. I am still trying to figure out how to post a picture of the vehicle that is tied with this comment so if you see a random picture of a black convertible in a yard, that's me haha.  …

Continue

Torque converter grab when idling in Drive

Posted by Cliff Johnston on June 14, 2021 at 8:47pm 2 Comments

Hi Everyone, been quite a while since i have been on here.

I have had an issue with the idle on my 64 Coupe Deville ever since i have had it.

With the Idle set high enough that it is smooth, but still a nice idle, the RPM seems only slightly too high for the stall of the Torque Converter. And therefore it tends to sit there and grab and lunge a bit. So until now, i have been putting the car in Neutral at the lights to stop this happening.

I've had the car dyno tuned and…

Continue

Can you help? Driveshaft Question....

Posted by Chris on May 30, 2021 at 8:55am 1 Comment

Hello!

Newbie to the group here - we have already found tons of invaluable information on the board, so thanks! We are restoring a 1963 Series 62 Convertible. We are wondering if anyone knows of a source to buy the propellor yoke flange (that bolts to the pinion flange) for the driveshaft? One of our ears partially broke off. Not sure if we can buy just the yoke flange as an aftermarket part, or if it has to be rebuilt by a welder/fab guy? Maybe a salvage yard for a source? Again, any…

Continue

Videos

  • Add Videos
  • View All

© 2021   Created by Jason Edge.   Powered by

Badges  |  Report an Issue  |  Terms of Service