Ronnie Lay's Discussions (105)

Discussions Replied To (95) Replies Latest Activity

"Steering gear on my 64 Sedan Deville was leaking, tried a rebuilt unit, it was junk,…"

Ronnie Lay replied Oct 16 to STEERING GEAR

14 Oct 23
Reply by Jason Edge

"I've had mine for years and bought them off a Snap-On truck. You might try the evil…"

Ronnie Lay replied Sep 18 to Power Steering Hose Nut

10 Sep 19
Reply by Jason Edge

"I have a set of these 12 point crows feet that work great for these applications. "

Ronnie Lay replied Sep 18 to Power Steering Hose Nut

10 Sep 19
Reply by Jason Edge

"I used this when I installed my Fleetwood letters, worked great, used to install all…"

Ronnie Lay replied Aug 29 to 1964 Fleetwood Letters installation

4 Aug 30
Reply by Markus R.

"It will probably be sometime in the fall when I will be able to swap out the rear li…"

Ronnie Lay replied Jun 10 to Rear trailing arm bushings- premature failure

83 Jun 11
Reply by Tony and Ginny 429

"Left negative feedback at Rare Parts, we'll see if they post it. Personally, I will…"

Ronnie Lay replied Jun 7 to Rear trailing arm bushings- premature failure

83 Jun 11
Reply by Tony and Ginny 429

"Here are 2 pictures 1st with Rare Parts bushing, clearly showing bushing being compr…"

Ronnie Lay replied Jun 7 to Rear trailing arm bushings- premature failure

83 Jun 11
Reply by Tony and Ginny 429

"Old bushings were removed by removing center rubber section (drilling) then cut a gr…"

Ronnie Lay replied Jun 5 to Rear trailing arm bushings- premature failure

83 Jun 11
Reply by Tony and Ginny 429

"I installed per the manual, with a torque wrench, tightening bolts only after car is…"

Ronnie Lay replied Jun 5 to Rear trailing arm bushings- premature failure

83 Jun 11
Reply by Tony and Ginny 429

"I did not replace the yoke bushings, just control arms, as I stated earlier they are…"

Ronnie Lay replied Jun 3 to Rear trailing arm bushings- premature failure

83 Jun 11
Reply by Tony and Ginny 429

RSS

Photos

  • Add Photos
  • View All

Forum

Tail pipe black stuff!

Started by Lambert Ross in 1963/64 Cadillac Specific Discussion. Last reply by Lambert Ross 1 hour ago. 10 Replies

any ideas how to clear the ugly black stuff shooting out from my tailpipe? After a long layover, it really messes up the garage floor. I assume its carbon but am not sure how best to react to it.…Continue

Had the 64 convert out for a spin

Started by Tony and Ginny 429 in 1963/64 Cadillac Specific Discussion 2 hours ago. 0 Replies

A two hour ride to my favorite restaurant on the water in Crystal River on the west coast  of central Florida —top down 77 degrees and 47 % humidity one outstanding day as will be the rest of the…Continue

Tags: Fl, River, Crystal

wanted balast tube for guide eye amp

Started by maurice lapoiinte in General Discussion. Last reply by Russ Austin 9 hours ago. 1 Reply

I am looking for a vaccum tube for my guide eye amp. tube #5947343 it call the ballast tube, its the shorter one of the 2 and only has a filament in it. fits 59-66 cadillacs with the guidematic…Continue

Current 1963/64 Cadillac Listings on eBay

Started by Jason Edge in For Sale. Last reply by Jason Edge 13 hours ago. 0 Replies

To see all 1963/64 Cadillacs Listed on eBay in the USA…Continue

Tags: ebay

Blog Posts

still need a driveshaft

Posted by wayne weaver on November 26, 2019 at 11:53am 0 Comments

well thank you UPS for losing the driveshaft that Russ Austin shipped me. 

however i still need a rear driveshaft section for my 63. mine has a vibration due to the bushing inside of it. its a shame because the ball and sockets in the cardian joints are perfect but it has a woble on the balancing machine. so .  still need the rear section. anyone have a good one ? is there driveshaft alternatives to use ? i am really considering an LS swap and since im fighting the driveshaft search…

Continue

63 guidematic issues

Posted by maurice lapoiinte on November 24, 2019 at 3:10pm 0 Comments

 So my 63 guide matic headlamps stay on low beam all the time. I have so far bypassed the system and everything works normal. I have been thru the trouble shooting in the manual but this is where the confusion begins.on my car when the power relay is powered I have low beam and when its not powered I have highbeam, this appears to be opposite what the diagnosis says should be correct.The wiring is all original and no wires have been mixed up.has anyone ever unplugged the 2 wire connector…

Continue

Another advantage of the Pertronix III

Posted by Doug Scarrow on November 23, 2019 at 11:12am 1 Comment

   Having tried both the II and III I can say the multispark feature of the III offers a smoother idle . It is also easier to install .Does not require removal of the distributor

Stuck at two red (dash) lights!

Posted by Jeff Kinzler on November 3, 2019 at 10:00pm 9 Comments

I hope someone can help solve these two electrical problems that appeared one after the other.

By way of background: The car, a '64 Eldorado has very limited use. It was at a restoration shop for 15 months until last January-  that supposedly did a bunch of wiring repairs including rebuilding the gas gauge that still hasn't worked properly, and the clock that hasn't worked, and re-soldering the broken wires in the drive door. All window and seat controls appear to be…

Continue

Videos

  • Add Videos
  • View All

© 2019   Created by Jason Edge.   Powered by

Badges  |  Report an Issue  |  Terms of Service