Last time I tried to use the wipers they wouldn't turn on. Finally, they did. Then I couldn't turn them back off. I had to unplug the wiper motor. The switch action does not feel as tight and definite as it should. I have it out of the car, and want to rehab it. Has anyone here done it? If so, where did you get replacements for the little rivets that hold it together?

Views: 246

Reply to This

Replies to This Discussion

I have never tried to refurbish the wiper dash switch  mainly since I have always had a big stash of them since starting to bring parts cars in in 1997. It is commendable and rewarding to refurbish anything, however, if you just wanted to buy one outright I have good working ones with average faces, minor pitting and wear for $25. If you want something really nice like the one below, I sell for $35.

Very Nice 63/64 Cadillac Windshield Wiper-Washer Switch - $35

I have pulled almost 4 dozen 63/64 Cadillac wiper washer switches over the past 20 years, but this is one of the best looking pieces I have brought in. Price is $35 + s/h. Email me at jasonedge@nc.rr.com

Never tried to refurb a wiper switch either.

Just to add, my wiper switch feels sloppy with little definition of where it's at while sliding it back and forth. My car overall is in excellent shape and I always just thought that is how it came from the factory. 

The one on ours is very good, slides easy and you can tell where each speed selection is without looking, but as they say, it never rains in Southern California too.

I doubt our wipers saw too much action prior to the overseas trip.

Just to add, the wiper switch and the wiper motor need to have a very good ground to work. Check the ground to the wiper motor. It is behind one of the mount bolts. 

The wiper switch grounds at the mount pins.

My wipers don't have any action when sliding the switch or pushing the fluid button. No noise or sense anything is trying to work. I've checked and replaced the fuse. Low priority, but is the ground a good place to start?

The wiper switch needs to be grounded to the frame of the dash. The 2 mount pins act as the ground. 

Then the wiper switch is grounded by a ground strap that is underneath a mount screw. Check the grounds and then perform the wiper motor test that is in the shop manual.

RSS

Photos

  • Add Photos
  • View All

Forum

Rear main seal. 63

Started by Kim K Kaiser in 1963/64 Cadillac Specific Discussion. Last reply by Tony and Ginny 429 16 hours ago. 3 Replies

My rms is leaking again.  I hv cked all other options for leaks and its none of those.  Ie, oil presdure, valve covers, etc.  So i called egge to order another one.  I asked the guy wat contack…Continue

Selling 1964 Coupe Deville Parts

Started by Gary Smiley in For Sale. Last reply by Gary Smiley 17 hours ago. 2 Replies

What I  have are many extra original, hard-to-find 1964 Cadillac Coupe Deville Parts (from donor car).…Continue

Tags: doors, hood, engine

Classic Cadillac Parts For Sale - Misc Items

Started by Jason Edge in For Sale. Last reply by Jason Edge yesterday. 275 Replies

I have posted a few Misc items over on my Classic Cadillac Parts Facebook page at…Continue

Tags: classic cadillac parts, classiccadillacparts

Blog Posts

Rumble Sound at 55-60 mph

Posted by Ray Schick on September 20, 2021 at 10:45pm 6 Comments

64 Coupe DeVille , while driving at 55-60 mph I have a oscillating rumble sound . Steering wheel does not shake or vibrate . Transmission mount looks good .Tires were replaced 2 years ago balanced and rebalanced recently. Axel bearings were just replaced, rear differential assembly was just replaced with a Posi track ,pinion bearings good. Fresh gear lube. Driveshaft checked and balanced the other day ,new center bearing installed and new bearing carrier assembly too. Trying to figure this…

Continue

1963 series 62 convertible transmission issue

Posted by Matthew VanDeWater on June 22, 2021 at 3:03pm 1 Comment

Hello I've been restoring a 63 for way to many years. Down to almost done, but have issue with trans linkage, when column in park shift rod 2 inches short. everything original. been trying to find picture of manual rod hooked up from under car to see position of linkage. was wondering if anybody has access for pictures. I wanted to see if my manual linkage is bent  wrong out of the trans if somebody dropped the trans or something. Doesn't make sense why it doesn't work. Thanks for any input…

Continue

New vehicle in the club

Posted by Patrick Westphal on June 17, 2021 at 4:00pm 1 Comment

I was successful in getting a vehicle from the New York contact I talked about at the last club meeting. I am still trying to figure out how to post a picture of the vehicle that is tied with this comment so if you see a random picture of a black convertible in a yard, that's me haha.  …

Continue

Torque converter grab when idling in Drive

Posted by Cliff Johnston on June 14, 2021 at 8:47pm 2 Comments

Hi Everyone, been quite a while since i have been on here.

I have had an issue with the idle on my 64 Coupe Deville ever since i have had it.

With the Idle set high enough that it is smooth, but still a nice idle, the RPM seems only slightly too high for the stall of the Torque Converter. And therefore it tends to sit there and grab and lunge a bit. So until now, i have been putting the car in Neutral at the lights to stop this happening.

I've had the car dyno tuned and…

Continue

Videos

  • Add Videos
  • View All

© 2021   Created by Jason Edge.   Powered by

Badges  |  Report an Issue  |  Terms of Service