Hey all, both the brake lights on my SDV are not making good connection. Drivers side works but is held tight with a piece of plastic wedged by the bulb and I can't get the right one to light the brake without pushing on it. They're either wore out or the springs are corroded. Tried the WD40 trick but that was an epic fail.

  Has anyone ever replaced any of the  rear light sockets on a '63?? They look like they're part of the tail light assembly. I've read up on how to get to the nuts that hold the assembly in place for removal but haven't found anything on replacing the sockets.

Thanks. Tom B

 

Views: 233

Reply to This

Replies to This Discussion

The sockets are crimped in place. The folded over metal will need to be ground off to get the socket out.

Sounds like a good time to install the LED tail lights from caddy Shack restorations.

Tom
You should be able to get replacement new centers for the sockets on ebay under your year car
I have seen them there they come in a Group of a few
I have not used them yet myself as no need for me so far
Hope that helps some

Enjoy

OK, thanks guys. Hmmm, I'll have to investigate the LED's 

Tom

Talk to Russ --about the Led rear lights he sells
He is the gentelman who suggested the Leds In his post
He is one of the true experts on our car and an excellent source of parts and fair excellent business practices
You will not go wrong dealing with Russ

Enjoy

Tom i bought light sockets at JT&T.com part # 2567F they fit a 3/4 inch hole. I grinded off the old socket removed all the reamaining parts, pressed in the new socket and adjusted the metal tabs.

Cees, Thanks for the heads up on the part #s

Tom B

RSS

Photos

  • Add Photos
  • View All

Forum

Classic Cadillac Parts For Sale - Misc Items

Started by Jason Edge in For Sale. Last reply by Jason Edge 35 minutes ago. 287 Replies

I have posted a few Misc items over on my Classic Cadillac Parts Facebook page at…Continue

Tags: classic cadillac parts, classiccadillacparts

64 caddie Brake drums

Started by mark zimmerman in 1963/64 Cadillac Specific Discussion. Last reply by Tony and Ginny 429 1 hour ago. 2 Replies

Are the front  brake drums the same as the rear ones? I had my garage install new drums on the car and now at 25-35 mph the car shakes like the  front wheels are going to fall off. Car has new brakes…Continue

Caddy Cruising with the Family

Started by Jason Edge in General Discussion 14 hours ago. 0 Replies

I've had a great couple of weeks entertaining family since Oct 11, and the 64 Caddy has played a big part.  Knowing aunts and uncles and many other relatives would be joining us for a celebration of…Continue

64 front passenger fender removal

Started by Chris Mcdougal in 1963/64 Cadillac Specific Discussion. Last reply by Jason Edge 16 hours ago. 1 Reply

Hey guys I have search around the discussion boards and can't find anything.. but trying to get this passenger front fender off of my 64 deville 6 window got all the obvious ones and the one behind…Continue

Tags: removal, Fender

Blog Posts

Rochester throttle body gasket

Posted by Phil on September 29, 2021 at 8:18am 5 Comments

Hello,  would anybody be able to tell me if I’m using the correct gasket on my Rochester throttle body? It doesn’t  look right to me.  I’m not sure if the carb actually ran with this gasket because I got it used with no history.  Any help would be appreciated …

Continue

Rumble Sound at 55-60 mph

Posted by Ray Schick on September 20, 2021 at 10:45pm 6 Comments

64 Coupe DeVille , while driving at 55-60 mph I have a oscillating rumble sound . Steering wheel does not shake or vibrate . Transmission mount looks good .Tires were replaced 2 years ago balanced and rebalanced recently. Axel bearings were just replaced, rear differential assembly was just replaced with a Posi track ,pinion bearings good. Fresh gear lube. Driveshaft checked and balanced the other day ,new center bearing installed and new bearing carrier assembly too. Trying to figure this…

Continue

1963 series 62 convertible transmission issue

Posted by Matthew VanDeWater on June 22, 2021 at 3:03pm 1 Comment

Hello I've been restoring a 63 for way to many years. Down to almost done, but have issue with trans linkage, when column in park shift rod 2 inches short. everything original. been trying to find picture of manual rod hooked up from under car to see position of linkage. was wondering if anybody has access for pictures. I wanted to see if my manual linkage is bent  wrong out of the trans if somebody dropped the trans or something. Doesn't make sense why it doesn't work. Thanks for any input…

Continue

New vehicle in the club

Posted by Patrick Westphal on June 17, 2021 at 4:00pm 1 Comment

I was successful in getting a vehicle from the New York contact I talked about at the last club meeting. I am still trying to figure out how to post a picture of the vehicle that is tied with this comment so if you see a random picture of a black convertible in a yard, that's me haha.  …

Continue

Videos

  • Add Videos
  • View All

© 2021   Created by Jason Edge.   Powered by

Badges  |  Report an Issue  |  Terms of Service