Kevin Campbell's Likes

July 2021

June 2021

April 2021

December 2020

August 2020

May 2020

April 2020

February 2020

November 2019

March 2019

February 2019

January 2019

December 2018

August 2018

June 2018

May 2018

February 2018

Photos

  • Add Photos
  • View All

Forum

Dash Grille - Adhesive?

Started by Chris McBride in General Discussion. Last reply by Chris Codd 43 minutes ago. 2 Replies

This dash grille likes to vacation from the dashboard.  Is it properly secured with an adhesive and, if so, what adhesive?  If so, what type?  If not, how is it secured?Thank you.…Continue

Wiper Blades for a '63?

Started by Karl Schwarz in 1963/64 Cadillac Specific Discussion. Last reply by Jason Edge 17 hours ago. 3 Replies

Is there anything special about the wiper blades I should use on my '63 Series 62 convertible? I have the original arms with the original blade brackets. I got Anco N-18R blades that should fit. I…Continue

Resistance wire removal or replacement

Started by Anders in 1963/64 Cadillac Specific Discussion. Last reply by Jason Edge 19 hours ago. 38 Replies

Resistance wire removal or replacement.If installing an electronic ignition system the resistance wire most likely has to be removed or bypassed. There are several ways to do this and the solution…Continue

Tags: wire, resistance

Alternators

Started by Thomas Yarri in 1963/64 Cadillac Specific Discussion. Last reply by Tony and Ginny 429 yesterday. 13 Replies

Has anyone had a bad alternator cause a weird misfire at idle, almost like the car is not sparking properly? I’ve upgraded to pertronix, replaced coil, plugs, plug wires and cap. Carburetor replaced…Continue

Blog Posts

Rumble Sound at 55-60 mph

Posted by Ray Schick on September 20, 2021 at 10:45pm 6 Comments

64 Coupe DeVille , while driving at 55-60 mph I have a oscillating rumble sound . Steering wheel does not shake or vibrate . Transmission mount looks good .Tires were replaced 2 years ago balanced and rebalanced recently. Axel bearings were just replaced, rear differential assembly was just replaced with a Posi track ,pinion bearings good. Fresh gear lube. Driveshaft checked and balanced the other day ,new center bearing installed and new bearing carrier assembly too. Trying to figure this…

Continue

1963 series 62 convertible transmission issue

Posted by Matthew VanDeWater on June 22, 2021 at 3:03pm 1 Comment

Hello I've been restoring a 63 for way to many years. Down to almost done, but have issue with trans linkage, when column in park shift rod 2 inches short. everything original. been trying to find picture of manual rod hooked up from under car to see position of linkage. was wondering if anybody has access for pictures. I wanted to see if my manual linkage is bent  wrong out of the trans if somebody dropped the trans or something. Doesn't make sense why it doesn't work. Thanks for any input…

Continue

New vehicle in the club

Posted by Patrick Westphal on June 17, 2021 at 4:00pm 1 Comment

I was successful in getting a vehicle from the New York contact I talked about at the last club meeting. I am still trying to figure out how to post a picture of the vehicle that is tied with this comment so if you see a random picture of a black convertible in a yard, that's me haha.  …

Continue

Torque converter grab when idling in Drive

Posted by Cliff Johnston on June 14, 2021 at 8:47pm 2 Comments

Hi Everyone, been quite a while since i have been on here.

I have had an issue with the idle on my 64 Coupe Deville ever since i have had it.

With the Idle set high enough that it is smooth, but still a nice idle, the RPM seems only slightly too high for the stall of the Torque Converter. And therefore it tends to sit there and grab and lunge a bit. So until now, i have been putting the car in Neutral at the lights to stop this happening.

I've had the car dyno tuned and…

Continue

Videos

  • Add Videos
  • View All

© 2021   Created by Jason Edge.   Powered by

Badges  |  Report an Issue  |  Terms of Service