The mast on my power antenna is stuck up.  I can hear the motor engage when I pull/push the knob, but no movement.  The mast seems be rigid on the push wire or rod which wont move.  Any thoughts about getting it unstuck?

Mike

Views: 56

Reply to This

Replies to This Discussion

I can't stand a conceited (stuck up) antenna. Sorry, couldn't resist : ). Anyway, do you hear a clicking sound when the antenna motor is running? There is a nylon cord that pushes/pulls the mast up & down. If the mast is simply stuck you will hear a clicking sound as the nylon cord grips and breaks loose trying the move the mast. In this case check the mast for any dents or bends that could be binding it. Also oil the mast with WD40 on steel wool. Try pushing the mast down manually while someone else pulls the knob. It can't be lowered unless the motor is winding up the nylon cord, If you don't hear a clicking the nylon cord or something else may be broken. In that case, you would need to remove the antenna and open it up to investigate. Do you have a shop manual? Instructions for removing the antenna are there.

Thanks, Kurt. I have a shop manual and will get to reading!

Often the nylon mast will break and can be replaced 

The motor makes a clicking sound but nothing moves in any direction if broken 

If the nylon mast is not broken I would think the motor that pulls the mast down ( and up )  WB the issue and requires removal inspection repair or replacement of parts or the unit 

Enjoy 

You can get a new antenna mast from CaddyDaddy.com    I use them all the time. 

RSS

Photos

  • Add Photos
  • View All

Forum

Classic Cadillac Parts For Sale - Misc Items

Started by Jason Edge in For Sale. Last reply by Jason Edge 1 hour ago. 275 Replies

I have posted a few Misc items over on my Classic Cadillac Parts Facebook page at…Continue

Tags: classic cadillac parts, classiccadillacparts

Dash Grille - Adhesive?

Started by Chris McBride in General Discussion. Last reply by Chris Codd 2 hours ago. 2 Replies

This dash grille likes to vacation from the dashboard.  Is it properly secured with an adhesive and, if so, what adhesive?  If so, what type?  If not, how is it secured?Thank you.…Continue

Wiper Blades for a '63?

Started by Karl Schwarz in 1963/64 Cadillac Specific Discussion. Last reply by Jason Edge 18 hours ago. 3 Replies

Is there anything special about the wiper blades I should use on my '63 Series 62 convertible? I have the original arms with the original blade brackets. I got Anco N-18R blades that should fit. I…Continue

Resistance wire removal or replacement

Started by Anders in 1963/64 Cadillac Specific Discussion. Last reply by Jason Edge 21 hours ago. 38 Replies

Resistance wire removal or replacement.If installing an electronic ignition system the resistance wire most likely has to be removed or bypassed. There are several ways to do this and the solution…Continue

Tags: wire, resistance

Blog Posts

Rumble Sound at 55-60 mph

Posted by Ray Schick on September 20, 2021 at 10:45pm 6 Comments

64 Coupe DeVille , while driving at 55-60 mph I have a oscillating rumble sound . Steering wheel does not shake or vibrate . Transmission mount looks good .Tires were replaced 2 years ago balanced and rebalanced recently. Axel bearings were just replaced, rear differential assembly was just replaced with a Posi track ,pinion bearings good. Fresh gear lube. Driveshaft checked and balanced the other day ,new center bearing installed and new bearing carrier assembly too. Trying to figure this…

Continue

1963 series 62 convertible transmission issue

Posted by Matthew VanDeWater on June 22, 2021 at 3:03pm 1 Comment

Hello I've been restoring a 63 for way to many years. Down to almost done, but have issue with trans linkage, when column in park shift rod 2 inches short. everything original. been trying to find picture of manual rod hooked up from under car to see position of linkage. was wondering if anybody has access for pictures. I wanted to see if my manual linkage is bent  wrong out of the trans if somebody dropped the trans or something. Doesn't make sense why it doesn't work. Thanks for any input…

Continue

New vehicle in the club

Posted by Patrick Westphal on June 17, 2021 at 4:00pm 1 Comment

I was successful in getting a vehicle from the New York contact I talked about at the last club meeting. I am still trying to figure out how to post a picture of the vehicle that is tied with this comment so if you see a random picture of a black convertible in a yard, that's me haha.  …

Continue

Torque converter grab when idling in Drive

Posted by Cliff Johnston on June 14, 2021 at 8:47pm 2 Comments

Hi Everyone, been quite a while since i have been on here.

I have had an issue with the idle on my 64 Coupe Deville ever since i have had it.

With the Idle set high enough that it is smooth, but still a nice idle, the RPM seems only slightly too high for the stall of the Torque Converter. And therefore it tends to sit there and grab and lunge a bit. So until now, i have been putting the car in Neutral at the lights to stop this happening.

I've had the car dyno tuned and…

Continue

Videos

  • Add Videos
  • View All

© 2021   Created by Jason Edge.   Powered by

Badges  |  Report an Issue  |  Terms of Service